Tesla M10 RDS 2016 crashes

Hi we are running multiple RDS 2016 STD servers with vmware 6 with passthrough mode GPUs

Dell R740
VMware ESXi, 6.5.0, 10175896
Driver = 411.81_grid_win10_server2016_64bit_international.exe

Daily multiple servers start to hang on black screen when users login. And when you are loggedin your start menu doesnt work or starting a app crashes. Looks like something crashes and starting any GUI doesnt work anymore. When I am already loggedon the crashed server and start mstsc.exe example it also crashes.

Events in eventvwr:
Log Name: Application
Source: NVWMI
Date: 7-1-2019 09:46:08
Event ID: 3
Task Category: (1)
Level: Information
Keywords: Classic
User: N/A
Computer: the computername
Description:
The description for Event ID 3 from source NVWMI cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

SERVICE_CONTROL_SESSIONCHANGE

the message resource is present but the message is not found in the string/message table

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="NVWMI" />
<EventID Qualifiers="16640">3</EventID>
<Level>4</Level>
<Task>1</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-01-07T08:46:08.449336600Z" />
<EventRecordID>237771</EventRecordID>
<Channel>Application</Channel>
<Computer>the computername</Computer>
<Security />
</System>
<EventData>
<Data>SERVICE_CONTROL_SESSIONCHANGE
</Data>
</EventData>
</Event>
############################################################################################
Log Name: Application
Source: NVWMI
Date: 7-1-2019 09:52:14
Event ID: 3
Task Category: (1)
Level: Information
Keywords: Classic
User: N/A
Computer: the computername
Description:
The description for Event ID 3 from source NVWMI cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

NVWMI - Windows Logon User Interface [c:/windows/system32/logonui.exe] was launched and [Windows Logon User Interface] profile was applied

the message resource is present but the message is not found in the string/message table

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="NVWMI" />
<EventID Qualifiers="16640">3</EventID>
<Level>4</Level>
<Task>1</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-01-07T08:52:14.006322600Z" />
<EventRecordID>237809</EventRecordID>
<Channel>Application</Channel>
<Computer>the computername</Computer>
<Security />
</System>
<EventData>
<Data>NVWMI - Windows Logon User Interface [c:/windows/system32/logonui.exe] was launched and [Windows Logon User Interface] profile was applied
</Data>
</EventData>
</Event>

Something for NVES to look into? Please open a support ticket to get it analyzed what’s going on.

Best regards
Simon

I know this is from a while ago but do you have any updates? We’re running in to the same error with a similar configuration.