Tesla M6 on ESXi 6. Unable to load the kernel module

Hi,

My host is VMware ESXi 6.0.0 build-5572656 Update 3 running on top of Cisco UCS B200 M4 with Tesla M6 hardware. Inside the VM i have 2 video cards detected:

00:0f.0 VGA compatible controller: VMware SVGA II Adapter
02:00.0 VGA compatible controller: NVIDIA Corporation Device 13f3 (rev a1)

I have tried 352.99 and 375.66 drivers (shown as compatible on nvidia’s webside), debian 8 and 9 64bit with no luck so far.
Same error persisted during all of the attempts:

ERROR: Unable to load the kernel module.

Relevant part of dmesg:

[ 951.953092] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=none,decodes=none:owns=none
[ 951.953206] NVRM: The NVIDIA GPU 0000:02:00.0 (PCI ID: 10de:13f3)
NVRM: installed in this system is not supported by the 375.66
NVRM: NVIDIA Linux driver release. Please see ‘Appendix
NVRM: A - Supported NVIDIA GPU Products’ in this release’s
NVRM: README, available on the Linux driver download page
NVRM: at www.nvidia.com.
[ 951.953506] nvidia: probe of 0000:02:00.0 failed with error -1
[ 951.953535] nvidia-nvlink: Nvlink Core is being initialized, major device number 251
[ 951.953553] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 951.953554] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 951.953556] nvidia-nvlink: Unregistered the Nvlink Core, major device number 251

Digging further:
pcie_port_pm=off as sugested here is not helping:

https://devtalk.nvidia.com/default/topic/971733/linux/-370-28-with-kernel-4-8-on-gt-2015-machines-driver-claims-card-not-supported-if-nvidia-is-not-primary-card/3

Following the advice under GPU Passthrough with ESXI 6 and setting ‘svga.present’ to ‘FALSE’ i get black screen and VM refuses to start:

Thanks in advance for any idea on this issue!
nvidia-bug-report.log.gz (48.3 KB)
nvidia-installer.log (2.13 KB)

Hiding the hypervisor?
hypervisor.cpuid.v0 = false

Though the supported way would be set it up as vGPU
http://www.vmware.com/content/dam/digitalmarketing/vmware/en/pdf/products/horizon/grid-vgpu-deployment-guide.pdf

Moreover, it’s in compute mode.

Solved by vendor. Thanks for the pdf!