There was a problem using GPIO

I didn’t have any problems with it before, but this error occurs when I use GPIO today. Cause it to not even run the sample

File "./simple_input.py", line 22, in <module>
    import RPi.GPIO as GPIO
  File "/opt/nvidia/jetson-gpio/lib/python/RPi/GPIO/__init__.py", line 1, in <module>
    from Jetson.GPIO import *
  File "/opt/nvidia/jetson-gpio/lib/python/Jetson/GPIO/__init__.py", line 1, in <module>
    from .gpio import *
  File "/opt/nvidia/jetson-gpio/lib/python/Jetson/GPIO/gpio.py", line 96, in <module>
    _board_info, _gpio_chip_base = gpio_pin_data.get_gpio_data(get_model())
  File "/opt/nvidia/jetson-gpio/lib/python/Jetson/GPIO/gpio.py", line 88, in get_model
    if int(os.listdir(version_path)[0][-3:]) >= 200:
    ValueError: invalid literal for int() with base 10: 'ion'

hello 2310351762,

may I know what’s your use-case, what’s the step you reproduce this failure.
you might also refer to https://pypi.org/project/Jetson.GPIO/ for Jetson.GPIO library.
thanks

My nano started to be abnormal these days. The first thing is the inability to use gpio, it worked fine before.
Now many commands don’t seem to work, such as

sudo reboot

, but in my memory, I don’t remember what I did to cause it to become like this.
It seems that some people have encountered the same trouble.
https://devtalk.nvidia.com/default/topic/1051608/jetson-nano/gpio-problem-on-nano/post/5337563/#

hello 2310351762,

could you please refer to Topic 1051608 and check “simple_input.py”. thanks

I had the same issue and solved by following the suggestion made by JerryChang and later needed to reinstall Jetson.GPIO using pip. The issue was solved afterwards.