Timestamp Problem of Omniverse ROS Bridge


I use ROS Bridge and PoseTree for send /tf topics.
I can send topics according to the documentation, but I am having problems.

Normally, I would set the /tf timestamp to the current time.(ros::Time::now(), and it is UNIX time)
However, when I send a /tf topic from Omniverse, the timestamp is set to the elapsed time from when I first pressed the play button.

The timestamps are very different.
Therefore, the /tf topic cannot be referenced by other ROS nodes.

Is there a good way to solve this problem?
There are not enough settings in the Omniverse details panel.

P.S. I tried disable /use_sim_time , but nothing change.


This is the content of the /tf topic sent by omniverse.

Usually, the timestamp contains the UNIX time of the timing. (ex. robot_state_publisher)

OK, I solved it myself.
I must have made a mistake.
I solved it by setting /use_sim_time to True on the ros side and publishing the /clock topic in ROS.

Thank you N.sannomi for the update.