Tlt_converter cannot find libnvinfer.so.7

Hi,

I want to try the tao toolkits.
It seems like I need to use tlt_converter in my Orin AGX.
Note: Where shall I download the tlt_converter?
I somehow downloaded the tlt_converter
However, when I ran it, it could not find libnvinfer.so.7
I was searching the forum and it seems it’s the Cuda version issue, I guess I have downloaded the old version of tlt_converter? Thx

root@ubuntu:/opt/nvidia/deepstream/deepstream-6.1/samples/experiment_dir_final# ./tlt-converter 
./tlt-converter: error while loading shared libraries: libnvinfer.so.7: cannot open shared object file: No such file or directory

This issue is DeepStream SDK related, I am moving this to the DeepStream SDK category for visibility.

Moving to TAO forum.

Please download the corresponding tao-converter.
See TAO Converter | NVIDIA NGC

Hi,

I am following this link on my Orin AGX, TAO Converter | NVIDIA NGC, but there is an error, still checking if the export path is not correct…
Thx

Btw, Do I use tao-converter or Tlt_converter? I am a little confused… If there is any tutorial of using the pbnet in my Orin AGX, that is all I need. Thx

wget --content-disposition https://api.ngc.nvidia.com/v2/resources/nvidia/tao/tao-converter/versions/v3.21.11_trt7.1_agx/zip -O tao-converter_v3.21.11_trt7.1_agx.zip
#unzip
sudo apt-get install libssl-dev
export TRT_LIB_PATH=”/usr/lib/aarch64-linux-gnu”
export TRT_INC_PATH=”/usr/include/aarch64-linux-gnu”
cd tao-converter_v3.21.11_trt7.1_agx/
pip3 install nvidia-pyindex
pip3 install nvidia-tao>=0.1.20
tao-converter
 
nvidia@ubuntu:~/Downloads/tao-converter_v3.21.11_trt7.1_agx$ tao-converter
bash: tao-converter: command not found

Can you run
root@ubuntu:/opt/nvidia/deepstream/deepstream-6.1/samples/experiment_dir_final# dpkg -l |grep cuda

Hi,

root@ubuntu:/opt/nvidia/deepstream/deepstream-6.1/samples/experiment_dir_final# dpkg -l |grep cuda
ii  cuda-cccl-11-4                             11.4.167-1                          arm64        CUDA CCCL
ii  cuda-command-line-tools-11-4               11.4.14-1                           arm64        CUDA command-line tools
ii  cuda-compiler-11-4                         11.4.14-1                           arm64        CUDA compiler
ii  cuda-cudart-11-4                           11.4.167-1                          arm64        CUDA Runtime native Libraries
ii  cuda-cudart-dev-11-4                       11.4.167-1                          arm64        CUDA Runtime native dev links, headers
ii  cuda-cuobjdump-11-4                        11.4.167-1                          arm64        CUDA cuobjdump
ii  cuda-cupti-11-4                            11.4.167-1                          arm64        CUDA profiling tools runtime libs.
ii  cuda-cupti-dev-11-4                        11.4.167-1                          arm64        CUDA profiling tools interface.
ii  cuda-cuxxfilt-11-4                         11.4.167-1                          arm64        CUDA cuxxfilt
ii  cuda-documentation-11-4                    11.4.167-1                          arm64        CUDA documentation
ii  cuda-driver-dev-11-4                       11.4.167-1                          arm64        CUDA Driver native dev stub library
ii  cuda-gdb-11-4                              11.4.167-1                          arm64        CUDA-GDB
ii  cuda-libraries-11-4                        11.4.14-1                           arm64        CUDA Libraries 11.4 meta-package
ii  cuda-libraries-dev-11-4                    11.4.14-1                           arm64        CUDA Libraries 11.4 development meta-package
ii  cuda-nvcc-11-4                             11.4.166-1                          arm64        CUDA nvcc
ii  cuda-nvdisasm-11-4                         11.4.167-1                          arm64        CUDA disassembler
ii  cuda-nvml-dev-11-4                         11.4.167-1                          arm64        NVML native dev links, headers
ii  cuda-nvprof-11-4                           11.4.166-1                          arm64        CUDA Profiler tools
ii  cuda-nvprune-11-4                          11.4.167-1                          arm64        CUDA nvprune
ii  cuda-nvrtc-11-4                            11.4.166-1                          arm64        NVRTC native runtime libraries
ii  cuda-nvrtc-dev-11-4                        11.4.166-1                          arm64        NVRTC native dev links, headers
ii  cuda-nvtx-11-4                             11.4.166-1                          arm64        NVIDIA Tools Extension
ii  cuda-samples-11-4                          11.4.166-1                          arm64        CUDA example applications
ii  cuda-sanitizer-11-4                        11.4.166-1                          arm64        CUDA Sanitizer
ii  cuda-toolkit-11-4                          11.4.14-1                           arm64        CUDA Toolkit 11.4 meta-package
ii  cuda-toolkit-11-4-config-common            11.4.167-1                          all          Common config package for CUDA Toolkit 11.4.
ii  cuda-toolkit-11-config-common              11.4.167-1                          all          Common config package for CUDA Toolkit 11.
ii  cuda-toolkit-config-common                 11.4.167-1                          all          Common config package for CUDA Toolkit.
ii  cuda-tools-11-4                            11.4.14-1                           arm64        CUDA Tools meta-package
ii  cuda-visual-tools-11-4                     11.4.14-1                           arm64        CUDA visual tools
ii  graphsurgeon-tf                            8.4.0-1+cuda11.4                    arm64        GraphSurgeon for TensorRT package
ii  libcudnn8                                  8.3.2.49-1+cuda11.4                 arm64        cuDNN runtime libraries
ii  libcudnn8-dev                              8.3.2.49-1+cuda11.4                 arm64        cuDNN development libraries and headers
ii  libcudnn8-samples                          8.3.2.49-1+cuda11.4                 arm64        cuDNN samples
ii  libnvinfer-bin                             8.4.0-1+cuda11.4                    arm64        TensorRT binaries
ii  libnvinfer-dev                             8.4.0-1+cuda11.4                    arm64        TensorRT development libraries and headers
ii  libnvinfer-doc                             8.4.0-1+cuda11.4                    all          TensorRT documentation
ii  libnvinfer-plugin-dev                      8.4.0-1+cuda11.4                    arm64        TensorRT plugin libraries
ii  libnvinfer-plugin8                         8.4.0-1+cuda11.4                    arm64        TensorRT plugin libraries
ii  libnvinfer-samples                         8.4.0-1+cuda11.4                    all          TensorRT samples
ii  libnvinfer8                                8.4.0-1+cuda11.4                    arm64        TensorRT runtime libraries
ii  libnvonnxparsers-dev                       8.4.0-1+cuda11.4                    arm64        TensorRT ONNX libraries
ii  libnvonnxparsers8                          8.4.0-1+cuda11.4                    arm64        TensorRT ONNX libraries
ii  libnvparsers-dev                           8.4.0-1+cuda11.4                    arm64        TensorRT parsers libraries
ii  libnvparsers8                              8.4.0-1+cuda11.4                    arm64        TensorRT parsers libraries
ii  nvidia-l4t-cuda                            34.1.1-20220516211757               arm64        NVIDIA CUDA Package
ii  python3-libnvinfer                         8.4.0-1+cuda11.4                    arm64        Python 3 bindings for TensorRT
ii  python3-libnvinfer-dev                     8.4.0-1+cuda11.4                    arm64        Python 3 development package for TensorRT
ii  tensorrt                                   8.4.0.11-1+cuda11.4                 arm64        Meta package of TensorRT
ii  uff-converter-tf                           8.4.0-1+cuda11.4                    arm64        UFF converter for TensorRT package
root@ubuntu:/opt/nvidia/deepstream/deepstream-6.1/samples/experiment_dir_final#  

So, your orin is TRT8.4.
You need to download the tao-converter of 8.4 version.

" https://catalog.ngc.nvidia.com/orgs/nvidia/teams/tao/resources/tao-converter/files?version=v3.22.05_trt8.4_aarch64 "

wget it and unzip , then chmod +x.

HI,

Still not working… Sorry, I don’t know how. >_<

README.txt (654 Bytes)
tao-converter (128.6 KB)

nvidia@ubuntu:~/Downloads/files$ chmod +x tao-converter 
nvidia@ubuntu:~/Downloads/files$ ls -l
total 136
-rw-rw-r-- 1 nvidia nvidia    654 May 26 20:16 README.txt
-rwxrwxr-x 1 nvidia nvidia 131712 May 26 20:16 tao-converter
nvidia@ubuntu:~/Downloads/files$ tao-

$ ./tao-converter

Silly me. :P
ok ok thx