Ubuntu 20.04 - Second monitor doesn't work, Ubuntu and Nvidia-settings detects it

After install Ubuntu 20.04 I tried to connect a second monitor via HDMI in my laptop ASUS ( Intel® Core™ i5-6300HQ CPU @ 2.30GHz × 4 ) - (Nvidia GeForce GTX 960M ) and Ubuntu and Nvidia settings detects I connected it, but the only thing I can see is a blank screen.

I tried with a Live USB, I have the same result. I tried to modify the xorg.conf (I added “Primay GPU” “Yes”) and nothing changes.

Anyone had this similar problem? Or someone can help me and tell me how can I try to fix this? On Ubuntu 18.04 and W10 it works perfectly.


Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).


There’s my nvidia-bug-report.log.gz ; I renamed it as “nvidia-bug-report-log”.
nvidia-bug-report.log (378.6 KB)

Thanks for answer me generix.

Looks like you’re in on-demand mode

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
  • I already have installed nvidia-prime,
  • I changed to nvidia
  • There’s no list called "blacklist-nvidia.conf on lib/ or etc/.
  • I updated initramfs
  • reboot, and tried with the second monitor. Nothing changes.

Please create a new nvidia-bug-report.log after switching to ‘nvidia’ profile and rebooting.

I upload the new nvidia-bug-report.log
nvidia-bug-report2.log (342.2 KB)

The nvidia gpu is on now, please try this:

nvidia-drm modeset is already to 0.

PS: driver Nvidia 440.64.

I’ve taken a closer look and the external monitor is connected to the intel gpu so it should work regardless of the nvidia gpu being on or off.
It’s also detected and used in both the nvidia-bug-report.log. Did you already check if it’s just disabled in Gnome’s control center? It should be shown there.

Yeah, I saw that on Nvidia-settings and I was wondering why Nvidia can detects it but I can’t see anything in the monitor. But on W10 it works perfectly.

This is what control center looks about Display:

But I just can only see a blank screen (no signal). When I start Ubuntu, and I’m in the grub the second monitor works perfectly, it’s only when I go to load the OS (after choose “Ubuntu” in the grub). So strange…

Please try setting a dfferent refresh rate/resolution.

I tried with all kind of rate and resolution. 800x600, 1368x768 and with 60Hz, 50Hz, 30Hz, 25Hz, 59,94Hz…and nothing changes. Just “no signal” :(

Rather odd, especially since it works on console. Rather sound like a problem with the intel gpu firmware. Please open a bug report on the Ubuntu bug tracker and confirm it still works with 18.04.

Aha, maybe’s something with Intel and Mesa then.

Thanks for your help generix, I appreciate it!

My HDMI monitor not detected also after I installed ubuntu20.4.
I attached my bug report, could you help?
Thanksnvidia-bug-report.log.gz (232.7 KB)