Ubuntu 22.04 can't get GPU to work

Hi there,

I’m running ubuntu 22.04. If I run nvidia-smi I get


+-----------------------------------------------------------------------------+
| NVIDIA-SMI 470.129.06   Driver Version: 470.129.06   CUDA Version: 11.4     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  Quadro K6000        Off  | 00000000:03:00.0  On |                  Off |
| 26%   34C    P8    21W / 225W |     10MiB / 12205MiB |      0%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|  No running processes found

If I run

sudo prime-select nvidia

I get

Error: no integrated GPU detected.

Processing: nvidia-bug-report.log.gz…
nvidia-bug-report.log (1.1 MB)

The log upload didn’t work. Please try unzipping and attach as text file.

Thanks generix, just uploaded the unzipped file in the first post

The kernel drivers are loaded but the Xserver ignores the nvidia drivers so it’s using the modesetting driver and uses software rendering. Unfortunately, the xorg config files weren’t caught in the log. Please run
find /etc/X11 /etc/X11/xorg.conf.d /usr/share/X11/xorg.conf.d -name "*.conf" -print -exec cat '{}' \; >allconfig.txt
and attach the output file allconfig.txt

allconfig.txt (6.7 KB)

Looks fine, everything in place. Maybe some timing problem, please try embedding the nvidia driver into the initrd:
https://forums.developer.nvidia.com/t/linux-mint-nvidia-driver-loads-with-startx-but-not-on-initial-startup/168262/2

I did the procedure but still get the error while running prime-select
nvidia-bug-report.log (1.2 MB)
allconfig.txt (6.7 KB)

The nvidia driver is now working fine.
The error message from prime-select is expected since you only have one gpu, the nvidia.