Unable to use GPU despite drivers installed Ubuntu 20.04 NVIDIA GeForce 920M

Hi, i am having problems to use the GPU NVIDIA GeForce 920M on Ubuntu 20.04.
I installed the drivers, but nvidia-settings gave the following:

ERROR: Unable to load info from any available system

(nvidia-settings:7748): GLib-GObject-CRITICAL **: 01:13:16.956: g_o
** Message: 01:13:16.960: PRIME: Requires offloading
** Message: 01:13:16.960: PRIME: is it supported? yes
** Message: 01:13:16.999: PRIME: Usage: /usr/bin/prime-select nvidi
** Message: 01:13:16.999: PRIME: on-demand mode: “1”
** Message: 01:13:16.999: PRIME: is “on-demand” mode supported? yes

while opening a window to select the prime profile; on the other part the
correct profile looks already selected, using the command sudo prime-select nvidia:

Info: the nvidia profile is already set

Anyway no process is using the GPU, nvidia-smi gives:

±----------------------------------------------------------------------------+
| NVIDIA-SMI 465.19.01 Driver Version: 465.19.01 CUDA Version: 11.3 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 NVIDIA GeForce … On | 00000000:04:00.0 N/A | N/A |
| N/A 38C P8 N/A / N/A | 0MiB / 2004MiB | N/A Default |
| | | N/A |
±------------------------------±---------------------±---------------------+
±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

Running nvidia-bug-report.sh points this error:
nvidia-bug-report.log (1.8 MB)

(I coudln’t load log.gz version for some reason)

DKMS make.log for nvidia-465.19.01 for kernel 5.4.0-73-generic (x86_64)
ven 14 mag 2021, 21:43:56, CEST
make[1]: ingresso nella directory «/usr/src/linux-headers-5.4.0-73-generic»
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (
echo >&2;
echo >&2 " ERROR: Kernel configuration is invalid.";
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";
echo >&2 " Run ‘make oldconfig && make prepare’ on kernel src to fix it.";
echo >&2 ; \

What i tried so far:

  • follow entirely this guide Installation Guide Linux :: CUDA Toolkit Documentation
    I had to solve a chain of dependency that made me install nvidia-driver-465 from 460, that should be installed, cat /proc/driver/nvidia/version:

    NVRM version: NVIDIA UNIX x86_64 Kernel Module 465.19.01 Fri Mar 19 07:44:41 UTC 2021
    GCC version: gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04)

  • remove the file /lib/modprobe.d/blacklist-nvidia.conf
    followed by sudo update-initramfs -u

  • remove the file /usr/share/X11/xorg.conf.d/20-intel.conf

  • check dkms status:

    nvidia, 465.19.01, 5.4.0-73-generic, x86_64: installed
    virtualbox, 6.1.10, 5.4.0-72-generic, x86_64: installed
    virtualbox, 6.1.10, 5.4.0-73-generic, x86_64: installed

  • install and switch to gdmlight from gdm3

  • check other errors in the forum, assuring that secure boot is disabled,
    xorg logs are included in the bug script

  • check requirements from /usr/share/doc/nvidia-driver-465/html/minimumrequirements.html, which are satisfied

I tried to follow the guidelines from If you have a problem, PLEASE read this first, but let me know if you need additional informations or want the output of some command.
At this point i lost hope, but thank you in advance for your help.