Lenovo Z40 (with GeForce 820M) can't use NVIDIA graphics properly on Kubuntu 18.10

So right now, I have nvidia-driver-415 installed on my laptop, Lenovo Z40 with GeForce 820M, running on Kubuntu 18.10. It doesn’t seem to be running right because audio is unbearable. Running nvidia-xconfig, then rebooting causes the display to switch to a lower resolution.

Running the recommended driver, nvidia-340, will render my laptop unusuable. I was only able to see the cursor on a black screen.

I have also tried nvidia-390, but there’s a lag between the video output and the input (like the menu slow to open).

When I open up NVIDIA settings, I get this:

$ nvidia-settings 

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


(nvidia-settings:10498): GLib-GObject-CRITICAL **: 10:43:52.764: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 10:43:52.769: PRIME: Requires offloading
** Message: 10:43:52.769: PRIME: is it supported? yes

In addition, I’m getting this message when I switch to NVIDIA driver: PKCS#7 signature not signed with a trusted key.

nvidia-bug-report.log.gz (90.2 KB)

Please delete /etc/X11/xorg.conf
You most likely have secure boot enabled so the nvidia modules can’t be loaded since they aren’t signed. Disable it in bios.
If that doesn’t resolve the issue, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I don’t have Secure Boot enabled, and I don’t have xorg.conf.

Also, I just attached the file in the original post. I also attached a screenshot of NVIDIA settings.

Edit: screenshot was marked as infected…why?

Edit2: uploaded another one.

It’s a Fermi gpu so you can only use the 390 driver. Please install that and create a new nvidia-bug-report.log. Don’t care for the virus warning, the forum software is often going haywire.

The driver page says its supported.

but I’ll give it a go, and see if that performance bug’s fixed.

There are different types of 820M, yours is not supported (GF117M)
http://us.download.nvidia.com/XFree86/Linux-x86_64/415.27/README/supportedchips.html
Your PCI-ID: 10de:1140

I found 820M (1140) in 410 & 415.

Out of curiosity, where exactly were they placed?

Of course you can find it there, right under the info:
[i]Below are the legacy GPUs that are no longer supported in the unified driver. These GPUs will continue to be maintained through the special legacy NVIDIA GPU driver releases.

The 390.xx driver supports the following set of GPUs:

GeForce 820M 1140 1019 0799 C[/i]

lspci outputs the pci id and chip type

My bad.

I’m blind.

So I switched to NVIDIA driver (v. 390). It’s running much better than ever compared the last time I used the driver.

However, NVIDIA’s settings still doesn’t reveal any info.

Gonna attach another bug report file, and others.

Edit: forgot to mention that the audio is fixed :-)

Edit2: is it normal for nvidia-detector to return “none”?
nvidia-bug-report.log.gz (666 KB)
Screenshot_20190117_230943.png
Screenshot_20190117_230905.png

There’s something wrong with your Nvidia gpu, it can’t be initialized so the intel is still used:

[    4.426229] NVRM: RmInitAdapter failed! (0x25:0x40:1101)
[    4.426361] NVRM: rm_init_adapter failed for device bearing minor number 0
[    4.426492] [drm:nv_drm_load [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000300] Failed to allocate NvKmsKapiDevice
[    4.427682] [drm:nv_drm_probe_devices [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000300] Failed to register device

See if the file /lib/modprobe.d/nvidia-kms.conf exists containing

options nvidia-drm modeset=1

If so, change 1 to 0 and run
sudo update-initramfs -u
and reboot. Create a new nvidia-bug-report.log afterwards.

You might also try kernel parameter

acpi_osi=! acpi_osi=\"Windows 2009\"

Setting it to 0 didn’t work. My laptop wouldn’t boot to

I have to totally delete it in order for it to boot properly, and I don’t think it worked.

Didn’t get to try the kernel parameter yet. Mind asking what it does exactly?
nvidia-bug-report.log.gz (667 KB)

Put simply, the kernel parameter tells your computer to configure the hardware for Windows 7 instead of Windows 10. Often is a workaround for failing dgpus.

The nvidia gpu is still failing to come up. If the kernel parameter doesn’t help you should test by installing Windows if there’s a general hardware failure.

I have a feeling it didn’t work.

Just looked at the log myself. It knows that the dGPU exists, but can’t find it.

Slightly off-topic (this concerns my desktop with GTX 1060), why is nvidia-detector returning “none” when nvidia-settings detects it like it should?

Also, what’s “PKCS#7 signature not signed with a trusted key”. That keeps showing up in the log.
nvidia-bug-report.log.gz (670 KB)

Still the same error, I fear it’s broken. You can only install Windows and see if it works there but I doubt that.
The PKCS#7 warning is nothing to be concerned about, it seems you’re running a kernel with module signing enabled but since secure boot is disabled it isn’t enforced.
Regarding your desktop, I don’t know about nvidia-detector but if nvidia-settings and nvidia-smi -q show it and glxinfo |grep vendor returns ‘Nvidia’ everything should be correct.