NVIDIA drivers not being detected in Fedora/KDE

I am using Fedora 30 with KDE environment. I have installed drivers through RPMFusion. Although drivers have been installed via dnf, but when I run nvidia-settings, I get this:

[sntshk@localhost ~]$ nvidia-settings 

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

And this with nvidia-smi:

[sntshk@localhost ~]$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I also tried nvidia-xconfig for new configuration. But after reboot, it stuck with the cursor on the top left side of the screen.

If there is any more information needed, please ask.

EDIT:

Output of lspci:

[sntshk@localhost ~]$ lspci | grep NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GM107GL [Quadro K620] (rev a2)
01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)

nvidia-bug-report.log.gz (63.4 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Yes, I have updated the post with bug report attachment. You can proceed.

You have secure boot enabled, so the nvidia driver can’t be loaded since it isn’t signed. Please disable secure boot in bios.
Furthermore, nouveau still loads, please create/edit /etc/modprobe.d/blacklist.conf adding

blacklist nouveau

Then update the initrd using
dracut -f

Wow!! Thank you very much. That solved a lot of problems. Thanks a lot!

Dear Sir, i installed the nvidia driver NVIDIA-Linux-x86_64-430.14 on Dell Inspiron 7460, but when run nvidia-settings show this message : ERROR: Unable to load info from any available system.
root@coruscant Downloads# uname -a
Linux coruscant.localdomain 5.0.17-300.fc30.x86_64 #1 SMP Mon May 20 15:36:26 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
root@coruscant Downloads# lspci |grep -E ‘VGA|3D’
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
root@coruscant Downloads# nvidia-smi
Sun May 26 20:16:13 2019
±----------------------------------------------------------------------------+
| NVIDIA-SMI 430.14 Driver Version: 430.14 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce 940MX Off | 00000000:01:00.0 Off | N/A |
| N/A 44C P0 N/A / N/A | 0MiB / 4046MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

It’s an Optimus notebook, so you will have to configure it to use PRIME
https://github.com/wildtruc/nvidia-prime-select
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910
For further issues, please open a new thread.

[ 0.000000] secureboot: Secure boot enabled
[ 0.000000] Kernel is locked down from EFI secure boot; see man kernel_lockdown.7

You have secure boot enabled, you need to disable it from the EFI/BIOS.
https://rpmfusion.org/Howto/NVIDIA#Secure_Boot

EDIT: Don’t blacklist nouveau as others said, It’s totally pointless , nouveau is disabled by others means using the “RPM Fusion” package. (but the secure boot has to be disabled for nvidia to be in a working state).

Hello, I am experiencing a similar problem as the OP but blacklisting nouveau and disabling secure boot have not fixed my problem. On startup my screen shows “nvidia kernel module missing falling back to nouveau”.

I have installed nvidia graphics drivers using rpmfusion (akmod-nvidia) however when i run nvidia-smi I get the error “command not found”.

Here is Nvidia-settings:
[alex@Alex-PC ~]$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

Here is the lspci:
[alex@Alex-PC ~]$ lspci | grep NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050 3GB] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)

Attached is the bug-report
nvidia-bug-report.log.gz (79.3 KB)

If there is anything you can do to help me I would appreciate it very much.

Hi @zovek182

By reading your bug log, the Nvidia driver is not correctly installed and nouveau is still active.
Please follow this instruction here -> https://rpmfusion.org/Howto/NVIDIA

Blacklisting nouveau

$ echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

Remove nouveau driver

$ dnf remove xorg-x11-drv-nouveau

Edit /etc/sysconfig/grub

Append ‘rd.driver.blacklist=nouveau’ to end of ‘GRUB_CMDLINE_LINUX=

## Example row ##
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rhgb quiet rd.driver.blacklist=nouveau"

Update grub2 conf

## For BIOS ##
grub2-mkconfig -o /boot/grub2/grub.cfg

## For UEFI ##
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Generate initramfs

## Backup old initramfs nouveau image ##
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
 
## Create new initramfs image ##
dracut /boot/initramfs-$(uname -r).img $(uname -r)

Install the latest Nvidia driver from here - Linux, Solaris, and FreeBSD driver 450.66 [long-lived branch release]

Before rebooting, edit your /etc/X11/xorg.conf as per below (you didn’t have it):

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    ModulePath      "/usr/lib64/xorg/modules"
    FontPath        "catalogue:/etc/X11/fontpath.d"
    FontPath        "built-ins"
EndSection

Section "Module"
    Load           "dri2"
    Load           "glamoregl"
    Load           "modesetting"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "DELL"
    ModelName      "a07a"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1050"
    BusID          "PCI:1@0:0:0"
    Option	       "Interactive" "0"
    Option         "NoLogo" "true"
    Option         "UseEDID" "true"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

If you were still unable to get it working, please attach a new nvidia-bug-report file again.