Cannot select NVIDIA GPU | Ubuntu 18.04.02 LTS | RTX 2070 Max-Q

Hi there! I’ve searched a couple things and i cannot get trough this, so i’m posting here hoping that someone can help me :)

I have a MSI GS65 Stealth 8SF with a RTX 2070 MAX-Q with Ubuntu 18.04.02 LTS, kernel 5.2.6-050206-generic, nvidia driver 430 (open source).

when i bought the PC i had some problems with battery drain, and i solved that issue switching to Nvidia profile on nvidia-settings (i was using Intel profile because it made sense for me that Intel was going to consume less power than Nvidia and because in my last PC i had to use Intel’s profile in order to increase battery duration). Since i switched to Nvidia profile PC was doing great, quiet, and battery lasted 3 to 4 hours.

Since a couple days ago i feel like i’m back to start: fans always spinning with noise, battery lasts less than 1 hour. In my way to diagnose the problem, i tried switching profiles to see if it changed anything. What i think is happening is that despite i select Nvidia profile in nvidia-settings, it never really uses it.

I think this because:

if i run
glxinfo|egrep “OpenGL vendor|OpenGL renderer*”

i always get this (in both profiles)
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® UHD Graphics 630 (Coffeelake 3x8 GT2)

if i check Nvidia Settings, despite Nvidia profile is selected, it shows me no options at all (and it showed a lot of options before (check attached screenshot)

if i run
nvidia-detector

it returns
none

Should i download driver 430.40 from https://www.nvidia.com/download/driverResults.aspx/149138/en-us?

Thanks in advance,
Cheers
nvidia-settings.png
nvidia-bug-report.log.gz (178 KB)

The kernel driver is missing. I noticed you have a non-standard 5.2 kernel installed, maybe you’re missing the header and dev package for it? Don’t use the .run installer, try reinstalling the 430 driver from ppa and watch the output.

Hi again, thanks for the quick answer

I reinstalled nvidia-driver-430 driver from command line (check screenshot) and restarted but the issue still persists.

I also reinstalled nvidia-kernel-common-430 and nvidia-kernel-source-430

Should i change to another kernel version? I’m not sure which specific version i had before the issue restarted but i think it was 5.1.X.

Cheers
nvidia-bug-report-20190806_1537.log.gz (143 KB)
nvidia-driver-430-reinstall.png

Unfortunately, there are no dkms logs on your system. Try to install the linux-headers package first, otherwise revert to a standard Ubuntu kernel.

Are you saying to install linux-headers and then reinstall nvidia-driver-430?

Yes. It should be the linux-headers package matching your running kernel, i.e. something like linux-headers-5.2.6-050206…

I could not reinstall linux-headers normally through command line, so i installed a new version (5.2.7). I use an app called Ubuntu Kernel Update Utility to do this. I installed this app back when i had the issue, to help me install kernel 5.

Anyway, the output is on the attachment (hope it has more info).

And then i reinstalled nvidia-driver-430 (output in attachment).

Aaaaand everything is the same :(

I’ve tried using kernel 4.20.17 and is the same. And before the issue i had kernel 5.1.X (don’t know exactly which, and i’ve tried with a couple).

I’m a little lost here :/ any ideas?

Thanks again
Cheers



nvidia-bug-report-20190807_0919.log.gz (130 KB)

What’s the output of
sudo /usr/lib/dkms/dkms_autoinstaller start

* dkms: running auto installation service for kernel 5.2.7-050207-generic [ OK ]

What’s the output of
ls -l /var/lib/dkms/nvidia/430.*/

It does not exist :(

ls -l /var/lib/dkms/nvidia/430.*/

no matches found: /var/lib/dkms/nvidia/430.*/

ls -l /var/lib/dkms/

-rw-r--r-- 1 root root 6 ago 31  2016 dkms_dbversion

cat /var/lib/dkms/dkms_dbversion

2.0.0

Something is wrong with your dkms install, try manually registering the nvidia driver with dkms:

  • check dkms status: dkms status
  • check if the directory /usr/src/nvidia-430.40 exists
  • register the driver: sudo dkms add -m nvidia -v 430.40
  • build the driver: sudo dkms build -m nvidia -v 430.40
  • install it: sudo dkms install -m nvidia -v 430.40
    Please post the output after each step.
  • dkms status
    (nothing appears, i even tried with sudo)

  • check if the directory /usr/src/nvidia-430.40 exists

total 216K
drwxr-xr-x 3 root root 4,0K jul 31 08:00 common
-rwxr-xr-x 1 root root 130K abr 22 21:54 conftest.sh
-rw-r--r-- 1 root root  849 jul 31 07:15 dkms.conf
-rw-r--r-- 1 root root 6,1K jul 21 11:19 Kbuild
-rw-r--r-- 1 root root 4,6K jul 21 11:19 Makefile
drwxr-xr-x 2 root root  12K ago  6 15:44 nvidia
drwxr-xr-x 2 root root 4,0K ago  6 15:44 nvidia-drm
drwxr-xr-x 2 root root 4,0K ago  6 15:44 nvidia-modeset
drwxr-xr-x 3 root root  36K ago  6 15:44 nvidia-uvm
drwxr-xr-x 2 root root 4,0K jul 31 08:00 patches
  • register the driver: sudo dkms add -m nvidia -v 430.40
Creating symlink /var/lib/dkms/nvidia/430.40/source ->
                 /usr/src/nvidia-430.40

DKMS: add completed.
  • build the driver: sudo dkms build -m nvidia -v 430.40
Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
unset ARCH; env NV_VERBOSE=1 'make' -j12 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.2.7-050207-generic IGNORE_XEN_PRESENCE=1 IGNORE_CC_MISMATCH=1 SYSSRC=/lib/modules/5.2.7-050207-generic/build LD=/usr/bin/ld.bfd modules........
Signing module:
 - /var/lib/dkms/nvidia/430.40/5.2.7-050207-generic/x86_64/module/nvidia-modeset.ko
 - /var/lib/dkms/nvidia/430.40/5.2.7-050207-generic/x86_64/module/nvidia-uvm.ko
 - /var/lib/dkms/nvidia/430.40/5.2.7-050207-generic/x86_64/module/nvidia.ko
 - /var/lib/dkms/nvidia/430.40/5.2.7-050207-generic/x86_64/module/nvidia-drm.ko
Secure Boot not enabled on this system.
cleaning build area...

DKMS: build completed.
  • install it: sudo dkms install -m nvidia -v 430.40
nvidia:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.2.7-050207-generic/updates/dkms/

nvidia-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.2.7-050207-generic/updates/dkms/

nvidia-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.2.7-050207-generic/updates/dkms/

nvidia-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/5.2.7-050207-generic/updates/dkms/

depmod...

DKMS: install completed.

And now PC freezes immediately after i logged in. I enter the password, press ENTER and PC freezes! I remember this happening with my last PC.

Please switch to vt before logging in and create a new nvidia-bug-report.log

I’ve change to vt and ran the nvidia-bug-report, attached it here.

I also tried to login with “Ubuntu with Wayland” (wheel in login screen) and it does not freeze. I am logged in with “Ubuntu with Wayland” to ber able to attach the report. And ATM PC seems normal again (no fans spinning like crazy, no overheating, battery is at 50% and say it last 2hours more).
nvidia-bug-report.log.gz (1.08 MB)

Is it possible to resolve the issue of PC freezing upon login with Xorg? I’m having a few issues with wayland, i guess its not so developed as i expected :/

It’s a bit puzzling, the DM Xorg session works fine but after login, the gpu runs into

Aug  7 21:36:52 jps kernel: [   19.261935] NVRM: Xid (PCI:0000:01:00): 31, Ch 00000018, intr 00000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_PROP_0 faulted @ 0x1_01040000. Fault is of type FAULT_PTE ACCESS_TYPE_VIRT_WRITE
Aug  7 21:36:52 jps kernel: [   19.554327] NVRM: Xid (PCI:0000:01:00): 13, Graphics Exception on GPC 0: 3D HEIGHT CT Violation. Coordinates: (0x80, 0x9c)

Are you using stock Ubuntu GDM/Gnome or any other DE?

Thanks! I have stock Ubuntu Gnome.

Maybe some generic trouble-shooting options:

  1. Please remove the kernel parameters “quiet splash”
    https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter
  2. Please add
__GL_MaxFramesAllowed=1

to /etc/environment
and check if it works after reboot.