All Drivers Not Working. GeForce 940M, Ubuntu 20.04, Kernel 5.4.0-51, Lenovo Ideapad

I’m running Ubuntu 20.04.1 LTS on a Lenovo Ideapad with Nvidia GeForce 940M card.

nvidia-driver-450 worked just fine until a few days ago when nvidia-smi would not work. Not sure what happened as I did not change anything with the system. nvidia-settings opens up bugged like this, where I can’t select anything other than prime profiles.

Screenshot from 2020-10-16 08-55-43

I have tried numerous ways to install different drivers available (clean install each time) but all have failed. Either through terminal or updater GUI. Checked and made sure every dependency is up to date.

prime-select query returns nvidia and I have tried switching to intel and back to nvidia, no errors, but reboot and the settings still says it is running on intel graphics. Secure boot is off.

I can’t figure out what’s wrong. How can I fix this?

System info:

$ inxi CPU: Dual Core Intel Core i7-6500U (-MT MCP-) speed/min/max: 3027/400/3100 MHz Kernel: 5.4.0-51-generic x86_64 Up: 1h 42m Mem: 2386.1/7755.6 MiB (30.8%) Storage: 447.13 GiB (11.5% used) Procs: 223 Shell: bash 5.0.17 inxi: 3.0.38

I suspect the problem is that drivers are listed N/A even though I have 455 currently installed. Could it be that the drivers are not “loaded” correctly?
On a complete purge of all nvidia drivers, the driver property here went to nouveau, however I could not find a way to select the nvidia card.
$ inxi -G Graphics: Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel Device-2: NVIDIA GM108M [GeForce 940M] driver: N/A Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.0-devel (git-19aaafd 2020-10-15 focal-oibaf-ppa)

$ ubuntu-drivers devices WARNING:root:_pkg_get_support nvidia-driver-455: package has invalid Support Betaheader, cannot determine support level == /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0 == modalias : pci:v000010DEd00001347sv000017AAsd00003829bc03sc02i00 vendor : NVIDIA Corporation model : GM108M [GeForce 940M] driver : nvidia-driver-450 - distro non-free driver : nvidia-driver-390 - distro non-free driver : nvidia-driver-455 - third-party free recommended driver : nvidia-driver-450-server - distro non-free driver : nvidia-driver-435 - distro non-free driver : nvidia-driver-440-server - distro non-free driver : nvidia-driver-418-server - distro non-free driver : xserver-xorg-video-nouveau - distro free builtin

$ sudo apt list nvidia-driver-* nvidia-driver-390/focal-updates,focal-security 390.138-0ubuntu0.20.04.1 amd64 nvidia-driver-390/focal-updates,focal-security 390.138-0ubuntu0.20.04.1 i386 nvidia-driver-418-server/focal-updates,now 418.152.00-0ubuntu0.20.04.1 amd64 [installed] nvidia-driver-418/focal,focal 430.50-0ubuntu3 amd64 nvidia-driver-430/focal-updates,focal-security 440.100-0ubuntu0.20.04.1 amd64 nvidia-driver-435/focal,focal 435.21-0ubuntu7 amd64 nvidia-driver-440-server/focal-updates 440.95.01-0ubuntu0.20.04.1 amd64 nvidia-driver-440/focal-updates 450.80.02-0ubuntu0.20.04.2 amd64 nvidia-driver-450-server/focal-updates 450.80.02-0ubuntu0.20.04.3 amd64 nvidia-driver-450/focal-updates 450.80.02-0ubuntu0.20.04.2 amd64 nvidia-driver-455/focal 455.23.04-0ubuntu0~0.20.04.1 amd64

When listing VGA Nvidia is not even listed as an option, should that be a problem?
$ sudo lspci -vnn | grep VGA 00:02.0 VGA compatible controller [0300]: Intel Corporation Skylake GT2 [HD Graphics 520] [8086:1916] (rev 07) (prog-if 00 [VGA controller])

My log from the one time I tried to install 450 with a .run file:
nvidia-installer.log (3.6 KB)

I can’t find nvidia-bug-report.sh as the drivers don’t seem to be running?

Would appreciate any help as this has been quite frustrating. TIA

Same issue here.