udpsrc not recognised at Gstreamer in ubuntu

Hi guys, I installed everything on ubuntu 18.04 but I am still getting the same error ;

gst-launch-1.0 -vvv udpsrc port=5000 ! application/x-rtp,encoding-name=H265,payload=96 ! rtph265depay ! h265parse ! queue ! avdec_h265 ! autovideosink sync=false async=false -e
WARNING: erroneous pipeline: no element "udpsrc"

I installed all the plugins too using this website: https://developer.download.nvidia.com/embedded/L4T/r32_Release_v1.0/Docs/Accelerated_GStreamer_User_Guide.pdf?RwF2iFfgLTZ6HQd4PvJNz9JDn2MJhbpxleN1IXGrC-PJDbC8C11yABNzURHImY4-NbN7Uyfzco1pHRwtIKFEuOlCcuIaSq2VisnVlEYx_k8IK12CXhG-yysmmCNif9BJaIkuuPSDcUSaN2Shc2xMG_8D_rIyAZxdGeVh8XQ7zZW4QNRNV40

sudo apt-get update
sudo apt-get install gstreamer1.0-tools gstreamer1.0-alsa \
 gstreamer1.0-plugins-base gstreamer1.0-plugins-good \
 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly \
 gstreamer1.0-libav
sudo apt-get install libgstreamer1.0-dev \
 libgstreamer-plugins-base1.0-dev \
 libgstreamer-plugins-good1.0-dev \
 libgstreamer-plugins-bad1.0-dev

How can I solve this? Thank you!

Hi,
Please check if cleaning cache helps.

$ rm .cache/gstreamer-1.0/registry.aarch64.bin

I still get the same error, any idea how to fix it?

A late answer but might be helpful for others:

  • Make sure you have sudo permissions to execute gst-launch-1.0

sudo gst-launch-1.0 -vvv udpsrc port=5000 ! application/x-rtp,encoding-name=H265,payload=96 ! rtph265depay ! h265parse ! queue ! avdec_h265 ! autovideosink sync=false async=false -e