Error while using gstreamer on mac to view stream from jetson nano via RTP for Hello World example

Hello, I installed gstreamer on my mac (running OS 11.2.3) to follow the Hello AI World videos, but as I run gstreamer I get the following error. Any ideas would be super helpful! thanks

ERROR: from element /GstPipeline:pipeline0/GstDecodeBin:decodebin0: Your GStreamer installation is missing a plug-in.

Additional debug info:

../gst/playback/gstdecodebin2.c(4720): gst_decode_bin_expose (): /GstPipeline:pipeline0/GstDecodeBin:decodebin0:

no suitable plugins found:

Missing decoder: H.264 (Constrained Baseline Profile) (video/x-h264, stream-format=(string)avc, alignment=(string)au, codec_data=(buffer)01424028ffe1000a6742402895a014016e4001000468ce3c80, level=(string)4, profile=(string)constrained-baseline)

ERROR: from element /GstPipeline:pipeline0/GstUDPSrc:udpsrc0: Internal data stream error.

Additional debug info:

../libs/gst/base/gstbasesrc.c(3127): gst_base_src_loop (): /GstPipeline:pipeline0/GstUDPSrc:udpsrc0:

streaming stopped, reason not-linked (-1)

Execution ended after 0:00:20.271924000

Looks like software decoder is missing on your mac: avdec_h264
Please install gstreamer1.0-libav and try again.

For RTSP, you can also try VLC player.

Thanks - that did the job.
I tried VLC and sometmes it works, sometimes not - I wonder if there is an issue with my wifi speed.