Unable to change the resolution of the built-in display

Hello everybody,

I have almost the same problem as described here: Unable to change extreme resolution

Unfortunately, the solution proposed by @generix doesn’t work in my case:

$ cvt -r 1920 1080 60
# 1920x1080 59.93 Hz (CVT 2.07M9-R) hsync: 66.59 kHz; pclk: 138.50 MHz
Modeline "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
$ xrandr --newmode "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
$ xrandr --addmode DP-2 "1920x1080R"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  43
  Current serial number in output stream:  44

Additional information:

OS: Ubuntu 20 04
GPU: Quadro M2200
GPU driver: nvidia-driver-510
I have two displays: built into my laptop (DP-2) and external (DP-4). The problem above is about built-in display, the external one works perfectly.

Also please find attached the report of nvidia-bug-report.sh (executed as root)
nvidia-bug-report.log (3.4 MB)

Please help.

You can’t add any modes to fixed frequencies panels, you’ll have to use scaling. Unfortunately, this isn’t very convinient with the nvidia driver. You can either use randr 1.1 to set those
xrandr --q1
gives scaled resolutions
or using metamodes
e.g.
nvidia-settings -a CurrentMetaMode="DP-2: nvidia-auto-select {viewportin=2560x1440;viewportout=3840x2160}"
(Don’t know if the syntax is correct)