Display issues

hello so i have a problem witch my display. it resolution not set correctly like it should be. i had that problem in Win10 i tried to change display resolution from control plane manualy, but it make it pixeled (i set correct Display Resolution) so than i figure out that a problem was Monitor is not changeing resolution only Win10 Os. so than i get back to Nvidia control plane and change it one opsion from auto to GFK or something like that and resolution change to right, but right now i’m using Linux so how can i found his opsion in there?

And SORRY FOR MY ENGLISH.

Nvidia Drivers are installed

Which distribution/desktop environment (DE)
in case of gnome use the gnome control center->devices->displays

i’m using Pop_OS.

A thing is there is no opsion in display settings for my original Screen resolution

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

ok
nvidia-bug-report.log.gz (122 KB)

It’s a TV set that’s either broken or very cheap, at least it doesn’t provide an EDID, i.e. it doesn’t tell which resolution it supports. What’s it’s native resolution, to add it manually?

so i have conncted two monitors one of them is monitor another is TV

resolution is bad on monitor

which one, hdmi or dvi?

HDMI

Ok, what resolution should that monitor have?
This might just be a broken hdmi cable, did you try another one already?

resol: 1680x1050

cable is not borken everything is ok.

Then the monitor is broken.
Try this:

xrandr --newmode "1680x1050_60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync
xrandr --addmode HDMI-0 "1680x1050_60"
xrandr --output HDMI-0 --mode "1680x1050_60"

Error code:

"X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 16 (RRCreateMode)
Serial number of failed request: 37
Current serial number in output stream: 37
"

Please try replacing _ with -

xrandr --newmode "1680x1050-60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync
xrandr --addmode HDMI-0 "1680x1050-60"
xrandr --output HDMI-0 --mode "1680x1050-60"

Still the same error.

So, I think figure it out. I need to change display setting called “timing” in Linux. I need to manually set changes on Horizontal and Vertical settings Like: “active pixels”, “front porch”, “synch width”… So how can I do that?

That’s the xrandr --newmode line doing, the numbers are the pixel and timing values.
The error you’re getting rather points to the mode already existing, can you please ignore the error and continue with the second and third command?

hey, sorry for late replay. a thing is i had this problem on Win10 before. My resolution settings on (Nvidia control plane) in Timing standard: Auto that’s why it look so pixeld i changed manual to

             Horizontal     Vertical

Active pixels: 1680 1050
Front porch (pixels) 104 1
Sync width (pixels) 184 3
Total pixels 2256 1087
Polarity Negative (-) Positive(+)

after typing this in Nvidia control plane my monitor was set to correct res.

But i don’t know how to do this on Linux?