Cannot get 1920x1080 on LCD-TV (...EDID for PYX 26LCDTV (DFP-1) contradicts itself...) with 304.88

Hello, this is my first post here. I need help to configure xorg.conf: do a correct ModeLine or set up a custom EDID I guess.

I am trying to make my LCD TV (HDMI-DVI-adaptered) to display at 1920x1080 in Linux Mint 15 in a TwinView setup with an 1920x1200 LCD (DVI) as primary display. I want them to show the same image - +0+60, positioned above each other in depth.

This worked on the exact same hardware with Ubuntu 11.04 / nvidia-270.41.
All I have replaced is the OS, Ubuntu 11.04 with Mint 15.

It also works in Windows XP to get 1920x1080 on the LCD TV.

Now with Mint 15 / nvidia-304.88 all I get is a black screen on TV or no signal and warnings in Xorg.0.log. I can make the LCD TV to display 1280x720 or even 800x600 (nvidia-auto-select).

The LCD display works fine, runs at 1920x1200.

Setup:

  • DFP-0: Iiyama ProLite E2607WSD (“Idek Iiyama PLE2607WSD”)
  • DFP-1: DMTech LT26XY (“PYX 26LCDTV”, PAL i guess)
  • Graphics card: NVIDIA GPU Quadro FX 4000 (NV40GL)
  • OS: Linux Mint 15, 64-bit
  • Driver: nvidia-304 (304.88, from standard-repos)

The error in the Xorg.0.log on an unmodified xorg.conf:

NVIDIA(GPU-0): The EDID for PYX 26LCDTV (DFP-1) contradicts itself: mode
NVIDIA(GPU-0):     "1280x720" is specified in the EDID; however, the EDID's
NVIDIA(GPU-0):     valid VertRefresh range (55.000-85.000 Hz) would exclude
NVIDIA(GPU-0):     this mode's VertRefresh (50.0 Hz); ignoring VertRefresh
NVIDIA(GPU-0):     check for mode "1280x720".

I have tried to build my own modelines using output from debug mode and have also tried to run slightly modified EDID:s with CustomEDID with no luck. Still getting black screen.

Display details from Xorg.0.log using Option “ModeDebug” “TRUE”, selected parts:

[ 4078.639] (–) NVIDIA(0): — EDID for PYX 26LCDTV (DFP-1) —
[ 4078.639] (–) NVIDIA(0): EDID Version : 1.3
[ 4078.639] (–) NVIDIA(0): Manufacturer : PYX
[ 4078.639] (–) NVIDIA(0): Monitor Name : PYX 26LCDTV
[ 4078.639] (–) NVIDIA(0): Product ID : 0x3770
[ 4078.639] (–) NVIDIA(0): 32-bit Serial Number : 0x013218a3
[ 4078.639] (–) NVIDIA(0): Serial Number String :
[ 4078.639] (–) NVIDIA(0): Manufacture Date : 2006, week 4
[ 4078.639] (–) NVIDIA(0): DPMS Capabilities :
[ 4078.639] (–) NVIDIA(0): Input Type : Digital
[ 4078.639] (–) NVIDIA(0): Prefer first detailed timing : Yes
[ 4078.639] (–) NVIDIA(0): Supports GTF : No
[ 4078.639] (–) NVIDIA(0): Maximum Image Size : 580 mm x 320 mm
[ 4078.639] (–) NVIDIA(0): Valid HSync Range : 30.0 kHz - 91.0 kHz
[ 4078.639] (–) NVIDIA(0): Valid VRefresh Range : 55.0 Hz - 85.0 Hz
[ 4078.639] (–) NVIDIA(0): EDID maximum pixel clock : 162.0 MHz

[…]

[ 4078.658] (II) NVIDIA(GPU-0): Validating Mode “1920x1080”:
[ 4078.658] (II) NVIDIA(GPU-0): 1920 x 1080 @ 60 Hz
[ 4078.658] (II) NVIDIA(GPU-0): Mode Source: EDID
[ 4078.658] (II) NVIDIA(GPU-0): Pixel Clock : 74.25 MHz
[ 4078.658] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1920, 2008
[ 4078.658] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 2052, 2200
[ 4078.658] (II) NVIDIA(GPU-0): VRes, VSyncStart : 1080, 1084
[ 4078.658] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 1094, 1124
[ 4078.658] (II) NVIDIA(GPU-0): H/V Polarity : +/+
[ 4078.658] (II) NVIDIA(GPU-0): Extra : Interlace
[ 4078.658] (II) NVIDIA(GPU-0): Mode is valid.

[…]

[ 4078.659] (II) NVIDIA(GPU-0): Validating Mode “1920x1080”:
[ 4078.659] (II) NVIDIA(GPU-0): 1920 x 1080 @ 60 Hz
[ 4078.659] (II) NVIDIA(GPU-0): Mode Source: EDID
[ 4078.659] (II) NVIDIA(GPU-0): Pixel Clock : 74.18 MHz
[ 4078.659] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1920, 2008
[ 4078.659] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 2052, 2200
[ 4078.659] (II) NVIDIA(GPU-0): VRes, VSyncStart : 1080, 1084
[ 4078.659] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 1094, 1124
[ 4078.659] (II) NVIDIA(GPU-0): H/V Polarity : +/+
[ 4078.659] (II) NVIDIA(GPU-0): Extra : Interlace
[ 4078.659] (II) NVIDIA(GPU-0): Mode is valid.

[…]

[ 4078.671] (II) NVIDIA(GPU-0): Validating Mode “1920x1080”:
[ 4078.671] (II) NVIDIA(GPU-0): 1920 x 1080 @ 60 Hz
[ 4078.671] (II) NVIDIA(GPU-0): Mode Source: X Server
[ 4078.671] (II) NVIDIA(GPU-0): Pixel Clock : 138.50 MHz
[ 4078.671] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1920, 1968
[ 4078.671] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 2000, 2080
[ 4078.671] (II) NVIDIA(GPU-0): VRes, VSyncStart : 1080, 1083
[ 4078.671] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 1088, 1111
[ 4078.671] (II) NVIDIA(GPU-0): H/V Polarity : +/-
[ 4078.671] (WW) NVIDIA(GPU-0): Mode is rejected: Only EDID-provided modes are allowed on
[ 4078.671] (WW) NVIDIA(GPU-0): PYX 26LCDTV (DFP-1) (continuous frequence modes not
[ 4078.671] (WW) NVIDIA(GPU-0): allowed).

= 1920x1080 interlaced SHOULD work.

Whole Xorg.0.log from “unmodified” xorg.conf is located here:
http://www.dotpointer.com/hosted/nvidia/Xorg.0.log

My current modified (non-working) xorg.conf, this one gives DFP-0=1920x1200 and DFP-1=black screen, but signal.


nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 304.88 (buildd@lamiak) Wed Apr 10 16:20:15 UTC 2013

Section “ServerLayout”
Identifier “Default Layout”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
Identifier “Configured Monitor”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Idek Iiyama PLE2607WSD”

# HorizSync       29.0 - 81.0
# VertRefresh     55.0 - 76.0
# Option         "ModeDebug" "TRUE"

# home-made using cyberwizzard.nl//blog-linux-gentoo-linux/147-debugging-nvidia-edid-resolutions.html
# -- signal + black screen
ModeLine       "1920x1080@60a" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync interlace
# -- signal + black screen
ModeLine       "1920x1080@60b" 74.18 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync interlace

# from http://www.arachnoid.com/modelines/
# no signal
# 1920x1080 @ 60.00 Hz (GTF) hsync: 69.54 kHz; pclk: 179.14 MHz
Modeline "1920x1080_60.00i" 179.14 1920 2040 2248 2576 1080 1082 1088 1158 -HSync +Vsync interlace

# from http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
# -- signal + black screen
Modeline "1920x1080@60i" 77.60 1920 1952 2240 2272 1080 1104 1110 1135 interlace

Option         "UseEDID" "False"
Option         "UseEDIDDpi" "False"

Option “DPI” “DFP-0:75x75;DFP-1:100x100”

Option         "DPI" "100x100"
Option         "UseEDIDFreqs" "False"
Option         "ModeValidation" "NoDFPNativeResolutionCheck"   
Option         "ExactModeTimingsDVI" "True"    
Option         "HorizSync" "DFP-0: 29-81; DFP-1: 30-91"
Option         "VertRefresh" "DFP-0: 55-76; DFP-1: 45-65"

EndSection

Section “Device”
Identifier “Configured Video Device”
Driver “vesa”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro FX 4000”
EndSection

Section “Screen”
Identifier “Default Screen”
Device “Configured Video Device”
Monitor “Configured Monitor”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “TwinView” “1”

Option “Stereo” “0”

Option         "metamodes" "DFP-0: 1920x1200 +0+0, DFP-1: 1920x1080@60i +0+60"

SubSection     "Display"
    Depth       24
Modes      "1920x1080@60a" "1920x1080@60b" "1920x1080_60.00i" "1920x1080@60i"
EndSubSection

EndSection


I’m quite sure I have done a lot of stuff wrong in the config as it is not working well, but this is the best I could come up with. Please correct me!

nvidia-bug-report-file, without logverbose 6 as I only get black screen on both LCD:s when doing CTRL+ALT+F1/F2/F3 etc:
http://www.dotpointer.com/hosted/nvidia/nvidia-bug-report.log.gz

EDID for PYX 26LCDTV taken from nvidia-settings:
http://www.dotpointer.com/hosted/nvidia/edid-26lcdtv.bin

I am able to boot into Windows XP 32-bit if necessary, to aquire EDID:s for example.

I am open for a solution - make modelines, modify EDID:s etc.

Would be nice to be able to watch a movie again …

Now I have been wasting some more hours in this matter.

I looked up the Hsync and Vsync values in the manual. It only speaks for the VGA input (which I’m not using), the V/H values are H: 30-60, V: 56-75. I tried this instead but no difference, still black display. Black display = the display is lit up and on, but only displays black. It does not fall off to “no signal”/turn off.

xrandr shows a lot of resolutions, including the 1920x1080.
By switching ModeLine between the 74.25 and 74.18 alternatives in previous post I may switch between “60.0” and “30.0” in the xrandr list. Guess it’s 50/60Hz. The TV has support for both modes interlaced in 1920x1080 according to the manual. No support for progressive. I’m fine with interlaced, but I want 1920x1080!

1280x768 is not the limit anymore, using xrandr I could push it up to 1280x1024.

I still think the error is in the ModeLine or wrong Hsync/Vsync values.

Will try to boot up Ubuntu 11.04 on a USB stick with the LCD TV as the only connected display and run xvidtune -show, maybe I can catch a working ModeLine.

Another alternative I’ve already tried is to install driver 270.41 in Mint 15, but this creates dependency problems.

Something is wrong with ViewPortOut too:
“[ 3503.067] (WW) NVIDIA(0): Unable to support custom viewPortOut 1024 x 576 +0 +96”

I tried to solve this by defining some viewports - have tried different variations:
Option “MetaModes” “DFP-0: 1920x1200 { ViewPortIn=1920x1200, ViewPortOut=1920x1200+0+0 }, DFP-1: 1920x1080 { ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+60 }”

But all this makes is a halting X server with an error in Xorg.0.log: “no screens found”. One guess I’ve been thinking of is that the viewport makes black borders - maybe the black borders could cover the whole display, making it all black?

I’ve made some steps forward though (I think…): now it’s only 1 of each section in the xorg.conf, one Monitor, one Screen and one Device. Don’t know if it is in the right direction, but trial and error proved that I don’t seem to need more.

For example, it does not care whether I put my ModeLine:s in one Screen or another Screen, it’s all merged as I’m running TwinView I guess. I’ve found out that there are different manual version for the drivers, so now I’m reading 304.88 version when looking up info. Makes things a little less confusing.

(ftp://download.nvidia.com/XFree86/Linux-x86_64/304.88/README/)

Installed Ubuntu 11.04 on a separate partition where I got 1920x1080 working with this LCD TV, running 270.41.

Connected only the LCD, and turned it successfully up to 1920x1080 and issued som probing commands:

xvidtune -show:

ModeLine "1920x1080"    74.25   1920 2008 2052 2200   1080 1084 1094 1124 +hsync +vsync interlace

nvidia-settings, looked at Screen 0 section:

Resolution: 56x60 dpi

I also found out that native resolution is 1280x768 by looking in nvidia-settings.

xrandr:

Screen 0: minimum 320 x 175, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1280x768       50.0    118.0
   1280x720       51.0     52.0
   1024x768       53.0     54.0     55.0     56.0
   960x720        57.0
   960x600        58.0
   960x540        59.0
   928x696        60.0
   896x672        61.0
   840x525        62.0     63.0     64.0     65.0
   832x624        66.0
   800x600        67.0     68.0     69.0     70.0     71.0     72.0     73.0     74.0     75.0
   800x512        76.0
   720x480        77.0
   720x450        78.0
   720x400        79.0
   680x384        80.0     81.0
   640x512        82.0     83.0     84.0
   640x480        85.0     86.0     87.0     88.0     89.0     90.0     91.0     92.0
   640x400        93.0
   640x350        94.0
   576x432        95.0     96.0     97.0     98.0     99.0    100.0
   512x384       101.0    102.0    103.0    104.0
   416x312       105.0
   400x300       106.0    107.0    108.0    109.0    110.0
   360x200       111.0
   320x240       112.0    113.0    114.0    115.0
   320x200       116.0
   320x175       117.0
   1920x1080     118.0*

118 (what it now is? frequency?) is 118.0 when working and not ~30.0 or ~60.0 as it is when not working. How I raise from 30-60 up to 118?

The manual does not tell Hsync/Vsync-values for the HDMI port, only the VGA (which can only go to 1280x768). So I’m missing those.

In Mint I tried ddcprobe (apt-get install xresprobe, then ddcprobe), but it halts att edidfail after mode listing.

EDIT:

Loaded driver 173.14.37 in Mint 15, also from standard repos. After adding Option “TwinView” “True” to the xorg.conf I now have 1920x1080 on the LCD TV.

My current working config with 173.14 working is as follows:

Section "ServerLayout"
	Identifier "Default Layout"
	Screen 0 "Screen0" 0 0
	InputDevice "Keyboard0" "CoreKeyboard"
	InputDevice "Mouse0" "CorePointer"
	Option "Xinerama" "0"
	Option "TwinView" "False"	
EndSection

Section "InputDevice"
	Identifier "Keyboard0"
	Driver "kbd"
EndSection

Section "InputDevice"
	Identifier "Mouse0"
	Driver "mouse"
	Option "Protocol" "auto"
	Option "Device" "/dev/psaux"
	Option "Emulate3Buttons" "no"
	Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
	Identifier "Monitor0"
	VendorName ""
	ModelName "Idek Iiyama PLE2607WSD"

	# for DFP-0
	HorizSync 29.0 - 81.0
	VertRefresh 55.0 - 76.0

	# for DFP-0 (LCD, from EDID)
	ModeLine "1920x1200" 154.00 1920 1968 2000 2080 1200 1203 1209 1235 +vsync -hsync

	# for DFP-1 (LCD TV, from 11.04, xvidtune -show)
	ModeLine "1920x1080"    74.25   1920 2008 2052 2200   1080 1084 1094 1124 +hsync +vsync interlace

EndSection

Section "Device"
	Identifier "Default nvidia Device"
	Driver "nvidia"
	VendorName "NVIDIA Corporation"
	BoardName "Quadro FX 4000"
	BusID "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device "Default nvidia Device"
	Monitor "Monitor0"
	DefaultDepth 24

	# for 173.14 - 304.88 does not seem to need it
	Option "TwinView" "True"

	Option "MetaModes" "DFP-0: 1920x1200+0+0,DFP-1:1920x1080+0+60"
	# for 304.88
	Option "MetaModeOrientation" "Clone"

	# 3 options to completely shut off EDID, not sure if needed with 173.14
	Option "UseEDID" "False"
	Option "UseEDIDDpi" "False"
	Option "UseEDIDFreqs" "False"

	Option "ConnectedMonitor" "DFP-0, DFP-1"

	# DPI set to what I found for LCD TV in 11.04
	Option "DPI" "56x60"
	Option "ModeValidation" "NoDFPNativeResolutionCheck" 

	Option "ExactModeTimingsDVI" "True" 

	Option "HorizSync" "DFP-0: 29-81; DFP-1: 30-91"
	Option "VertRefresh" "DFP-0: 55-76; DFP-1: 45-65"

	Option "CoolBits" "4"

	SubSection "Display"
	        ViewPort 0 0
		Virtual 1920 1200
		Depth 24
		# for single-display-mode, possibly not needed
		Modes "1920x1200" "1920x1080"
	EndSubSection
EndSection

I tried removing all the UseEDID options, modelines etc and use a minimal config.
With 173.14 I got the same desired 1920x1080 resolution, but with EDID warnings
(see post 1) about contradiction again.

Conclusion: Driver 304.88 (or somewhere above 270.41) is broken, possibly when it comes to parsing/accepting EDID.

270.41 works in Ubuntu 11.04 but, 173.14 works in Mint 15 but not 304.88.

Probably the best bet would be to try your EDID with the supposedly working driver and the broken driver to see if the timings changed at all somehow.

On Mint 15 could you please move your old xorg.cong file, generate default xorg.conf file using nvidia-xconfig, startx in verbose mode to repro the issue and provide nvidia bug report logs for working and non-working case?