Linux Mint with latest nvidia drivers and 4K monitor only with 30Hz

Hello

Have video card GeForce GTX 770M and monitor Dell U2718Q which is working properly on Windows with resolution 38402160 60Hz via display port. But under Linux Mint 19.2 I can’t set 60Hz with resolution 38402160, so only 30Hz available for me. I have installed latest nvidia drivers. Also played with xrandr with no luck :( Please help.

All details and cases here - https://forums.linuxmint.com/viewtopic.php?f=59&t=306388

Thanks in Advance

According to the info in that thread, the problem is that the monitor and the gpu are negotiating a 330MHz link speed which isn’t enough for 4k@60. Did you already try a different cable and check the monitor’s OSD that it is switched to DP 1.2?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hello

Lets summarize: I have one notebook Asus ROG and I connected display Dell U2718Q via mini DP to DP and this cable provided with monitor by the vendor so this cable is ok. When my notebook is booting first display is of course display which is on the notebook but when it lead to login screen it is switching automatically to external display Dell U2718Q. In nvidia config panel I switched off display of the notebook so since login screen only one display is working and it is Dell U2718Q. Also please note that my notebook with external display is working properly on 4k with 60Hz on windows 10 out of the box without any changes. So it means that we have some issue on Linux level but we need to find out what is the problem.

With hope
Thanks in Advance
nvidia-bug-report.log.gz (1.04 MB)

Definitely not the cable, link seems to be fine:

[    15.628] (--) NVIDIA(GPU-0): DELL U2718Q (DFP-3): connected
[    15.628] (--) NVIDIA(GPU-0): DELL U2718Q (DFP-3): Internal DisplayPort
[    15.628] (--) NVIDIA(GPU-0): DELL U2718Q (DFP-3): 960.0 MHz maximum pixel clock

so it’s a bit odd where those 330MHz come from the driver checks the modes against.
Please add

Option "ModeDebug" "true"

to the device section of your xorg.conf and create a new nvidia-bug-report.log.
Though you already did that for the Mint thread, you posted only excerpts. Having the full log is necessary.

Hello

Done. Please see in attach.

Hm… It seems like 330.0 is for display of my notebook monitor…So X fails due to it was not switched to DELL U2718Q before login screen. But it is not possible to switch to DELL U2718Q untill login screen in my case. Is it true? )

Thanks in Advance
nvidia-bug-report.log.gz (1.04 MB)

Hello

Still waiting response. Hope we will do it and I will have possibility to use 60Hz on 4K display.

With hope
Thanks in Advance

The EDID in your logs from Dell U2718Q monitor decodes to reveal this modeline:
Detailed mode: Clock 533.250 MHz, 609 mm x 349 mm
3840 3888 3920 4000 hborder 0
2160 2163 2168 2222 vborder 0
+hsync -vsync

That video mode is correct for reduced vertical blank 3840x2160 @ 60Hz (FOSS modeline calculators are not completely trustworthy or up-to-date).
And it is the mode you require…

But for some reason the Nvidia driver does not list this modeline at all…
Bit sad when even the most basic function (EDID) does not work properly.

Hello

Thanks for info. Is it possible to fix it somehow? How can we resolve this issue?

Thanks in Advance

The /var/log/Xorg.0.log included in your log file also shows no information/evidence of 'option “ModeDebug” “true” '…
Almost like the /etc/X11/xorg.conf is being ignored or overloaded by stuff in /xorg.conf.d/.

I use custom modelines to force my 4K monitor to do 24Hz & 50Hz; the monitor EDID only has 30 & 60Hz.

A better modeline for 59.94Hz video could be

533.00 3840 3888 3920 4000 2160 2163 2168 2223 +hsync -vsync

Hello

Maybe it was necessary to reboot after changing xorg.conf? Done and please check once again.

Thanks in Advance
nvidia-bug-report.log.gz (1.08 MB)

That’s better.
Yes. Have to reboot or restart desktop-manager to use changed xorg.conf.

The 60Hz 4K modeline shows up now.

It is rejected:
[ 8.859] (WW) NVIDIA(GPU-0): Mode is rejected: DP Bandwidth check failed.
[ 8.859] (WW) NVIDIA(GPU-0): GPU extended capability check failed.
[ 8.859] (WW) NVIDIA(GPU-0): Mode “3840x2160_60” is invalid.

Must have decided the DP link number is to small or GPU is too slow.
1000s of lines of debug cruft / info & the driver makes no mention of the GPU extended capability check.

Maybe have to find another magic debug option keyword or:

Option “ModeValidation” “GPU-0: NoExtendedGpuCapabilitiesCheck”
Option “ModeValidation” “GPU-0.DFP-3: NoExtendedGpuCapabilitiesCheck” ???

or “GPU-0.DFP-3: NoDisplayPortBandwidthCheck”

The driver docs does not show option cmd construct for " CapabilityCheck" so may or may not have the port DP-0 or monitor DFP-3.

The 30Hz 4K modeline invalidates the EDID vertical freq (refresh rate):
[ 8.858] (II) NVIDIA(GPU-0): The EDID for DELL U2718Q (DP-0) contradicts itself: mode
[ 8.858] (II) NVIDIA(GPU-0): “3840x2160” is specified in the EDID; however, the EDID’s
[ 8.858] (II) NVIDIA(GPU-0): valid VertRefresh range (49.000-86.000 Hz) would exclude
[ 8.858] (II) NVIDIA(GPU-0): this mode’s VertRefresh (29.981 Hz); ignoring VertRefresh
[ 8.858] (II) NVIDIA(GPU-0): check for mode “3840x2160”.

but it uses it anyway!

Hello

Thanks for info but unfortunately I don’t know what to do with info above. Which exactly xorg.conf I can check or what do to next?

Thanks in Advance

Stick this into your /etc/X11/xorg.conf or /etc/X11/xorg.conf.d/nn-nvidia.conf

Option “ModeValidation” “GPU-0.DFP-3: NoDisplayPortBandwidthCheck”

add it before or after

Option “ModeDebug” “true”

Reboot or restart X server.

If that does not work than try adding this:
Option “ModeValidation” “GPU-0: NoExtendedGpuCapabilitiesCheck”

You’ll need to eyeball the /var/log/Xorg.0.log for errors/warnings about exact syntax/semantics.

If you use /etc/X11/xorg.conf some helpful installer or utility will trash it for you.

So later, make a filename.conf file in xorg.conf.d folder so your special setup does not get trashed.
In this file cut & paste the useful bits from xorg.conf.
A lot of the file is just cruft.

Hello

There is no such folder on my PC /etc/X11/xorg.conf.d/nn-nvidia.conf

To which example from those https://forums.linuxmint.com/viewtopic.php?f=59&t=306388&p=1728586#p1728586 it is necessary to add
Option “ModeValidation” “GPU-0.DFP-3: NoDisplayPortBandwidthCheck”?

Thanks in Advance

My eyes hurt looking at that seagull splatter.
I can’t invest in a study of your timeline vs your changes reported in that forum.

As I said, worry about /xorg.conf.d/my_nvidia.conf later…

I would comment out all the things in your xorg.conf file you don’t understand & par it right back.
Start with incremental steps that can be demonstrated to work.

You do NOT need a custom modeline; your monitor has correct EDID (not correct for 59.94Hz video).

Hello

First variant is not working, please see logs here - https://termbin.com/m5l8q
Second one working but refresh rate only 30Hz and I can’t select 60Hz - https://termbin.com/42p8

Latest xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 418.56

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2718Q"
    HorizSync       10.0 - 137.0
    VertRefresh     49.0 - 86.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 770M"
    Option "ModeDebug" "true"
    Option "ModeValidation" "GPU-0: NoExtendedGpuCapabilitiesCheck"
EndSection

Section "Screen"

# Removed Option "metamodes" "DP-1: 1920x1080_24 +0+0 {AllowGSYNC=Off}"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "metamodes" "DP-1: 3840x2160_60 +0+0 {AllowGSYNC=Off}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

nvidia-bug-report.log.gz (1.08 MB)

That first log states:
[ 8.113] () NVIDIA(GPU-0): Mode Validation Overrides for DELL U2718Q (DFP-3):
[ 8.113] (
) NVIDIA(GPU-0): NoDisplayPortBandwidthCheck
[ 8.113] (II) NVIDIA(GPU-0): Validating Mode “3840x2160_60”:
[ 8.113] (II) NVIDIA(GPU-0): Mode Source: EDID
[ 8.113] (II) NVIDIA(GPU-0): 3840 x 2160 @ 60 Hz

snip

[ 8.113] (II) NVIDIA(GPU-0): Mode “3840x2160_60” is valid.

and later

[ 8.141] (II) NVIDIA(GPU-0): — Modes in ModePool for DELL U2718Q (DFP-3) —
[ 8.141] (II) NVIDIA(GPU-0): “nvidia-auto-select” : 3840 x 2160 @ 60.0 Hz (from: EDID)
[ 8.141] (II) NVIDIA(GPU-0): “3840x2160” : 3840 x 2160 @ 60.0 Hz (from: EDID)
[ 8.141] (II) NVIDIA(GPU-0): “3840x2160_60” : 3840 x 2160 @ 60.0 Hz (from: EDID)
[ 8.141] (II) NVIDIA(GPU-0): “3840x2160_30” : 3840 x 2160 @ 30.0 Hz (from: EDID)

Success.

I would comment out the line “metamodes” “DP-1…”
or try change it to:
Option “metamodes” “DFP-3: 3840x2160_60 +0+0”

The 2nd log shows 60Hz mode is invalid:
[ 8.043] (WW) NVIDIA(GPU-0): Mode is rejected: DP Bandwidth check failed.
[ 8.043] (WW) NVIDIA(GPU-0): GPU extended capability check failed.
[ 8.043] (WW) NVIDIA(GPU-0): Mode “3840x2160_60” is invalid.

So please confirm that next should work:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 418.56


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2718Q"
    HorizSync       10.0 - 137.0
    VertRefresh     49.0 - 86.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 770M"
    Option "ModeDebug" "true"
    Option "ModeValidation" "GPU-0.DFP-3: NoDisplayPortBandwidthCheck"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-3"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Hm…

Now in nvidia panel I can select 60HZ! BUT! Monitor says there is no signal at all and switched to sleep mode :( https://termbin.com/ua1j

Also nvidia panel proposed next xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 418.56

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AU Optronics Corporation"
    HorizSync       66.0 - 66.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 770M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "LVDS-0: nvidia-auto-select +922+2160 {AllowGSYNC=Off}, DP-1: 3840x2160_60 +0+0 {AllowGSYNC=Off}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Please help
Thanks in Advance
nvidia-bug-report.log.gz (1.12 MB)

In your previous post with the 2 logs…
What do you mean by “First variant is not working” ?

Did you have Option “AllowEmplyConfig…” etc in that xorg.conf?

The exact behaviour of the Nvidia driver to clauses/statements in xorg.conf is very hard to predict.
The file is an obsolete format & likely just parsed end to end now.

Change one thing & test…

You could try adding this to Screen section:
Option “PreferredMode” “3840x2160_60.00”

But I don’t think this will work.
Your monitor is a good compliance test & linux driver on your h/w fails.
Your device is a mobile hybrid graphics setup? Possibly has some hardware design quirk.
Clearly, the linux driver does not do something the windows driver does.