Graphic issue with GTX970M and all Nvidia drivers

Hi guys,

Since i bought my laptop, a MSI GT72-2QD Dominator, i have a big problem when i launch Linux with Nvidia driver. I’m French so i don’t know how to explain correctly in English the issue so i took a video with my mobile. My issue on Youtube :
http://youtu.be/o2wcY4bSTyk

I tried differents drivers versions and only one driver works without this problem (Nvidia driver bêta 346.22 and 346.16). Others driver like 343.36, 346.35, 346.47, 346.53 and 349.12 have this issue.

I don’t know where come from the problem and how resolv it. To help you, i post the both “nvidia-bug-reports” from 346.22 (driver version which works) and 349.12 (latest version which does not work).

Thanks,
Maxime

nvidia-bug-report.346.22.log.gz (82.2 KB)
nvidia-bug-report.349.12.log.gz (81.8 KB)

I add that the Nvidia 346.22 is the only one which find a freshrate to 75Hz for my Screen. Others drivers which don’t work find only 60Hz … Same thing for xrandr command.

I forgot to mention that if i use a HDMI cable to use my screen TV instead of the screen’s laptop, this problem disappear.

I discuss with Arthur Huillet from Nvidia and for him and my tests, it’s probably a problem when DisplayPort.

There is a workaround to fix this issue while waiting for a new driver ?

I, and a few others, have reported similar issues on the msi forums:

https://forum-en.msi.com/index.php?topic=255055.0
https://forum-en.msi.com/index.php?topic=250805.0

Hello,
I have exactly the same problem with my msi gt72 2qd notebook. Running Windows 8.1 all is fine.
But when i use my Linux OS the screen shivers as seen in the video above(linked by OdelPasso).
I tried all of the newest drivers which support the gforce gtx 970m graphic card. All drivers showed the same shivering screen.
I already contacted the Nvidia support and explained my problem.

I hope there will be soon a driver which solves this problem.

io
nvidia-bug-report.log.gz (85.7 KB)

I’m also having the exact same problem, I have a Gigabyte P37x with a 980m and intel 4600HD.
I also hope there’s some fix for this.

Just wanted to say that I installed ubuntu 15 and it’s working properly. I even installed the restricted drivers and they’re good.

What is your kernel version? Nvidia driver version? Modeline for the laptop display (output of xrandr)?

I have the same problem.

Hardware: MSI GT72-2QD Dominator with GTX970m
Operating System: Ubuntu 15.04

I tried so far:

  • 346.59
  • 349.16

Furthermore I tried to install 346.22 as the thread-author mentioned using the .run-file from the nvidia website. But I had no luck with that one on Ubuntu 15.04.

Here are the modlines of the currently running Gallium 0.4 on llvmpipe (LLVM 3.6, 256 bits) driver:

[     4.323] (II) modeset(0): Printing probed modes for output eDP-0
[     4.323] (II) modeset(0): Modeline "1920x1080"x60.0  138.00  1920 1968 2000 2070  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
[     4.323] (II) modeset(0): Modeline "1920x1080"x60.0  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync (67.2 kHz e)
[     4.323] (II) modeset(0): Modeline "1920x1080"x59.9  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.6 kHz d)
[     4.323] (II) modeset(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
[     4.323] (II) modeset(0): Modeline "1680x1050"x59.9  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync (64.7 kHz d)
[     4.323] (II) modeset(0): Modeline "1600x1024"x60.2  103.12  1600 1600 1656 1664  1024 1024 1029 1030 +hsync +vsync (62.0 kHz d)
[     4.323] (II) modeset(0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz d)
[     4.323] (II) modeset(0): Modeline "1400x1050"x60.0  121.75  1400 1488 1632 1864  1050 1053 1057 1089 -hsync +vsync (65.3 kHz e)
[     4.323] (II) modeset(0): Modeline "1280x1024"x59.9  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync (63.7 kHz e)
[     4.323] (II) modeset(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz d)
[     4.323] (II) modeset(0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz d)
[     4.323] (II) modeset(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz d)
[     4.323] (II) modeset(0): Modeline "1280x960"x59.9  101.25  1280 1360 1488 1696  960 963 967 996 -hsync +vsync (59.7 kHz e)
[     4.323] (II) modeset(0): Modeline "1360x768"x59.8   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync (47.7 kHz d)
[     4.323] (II) modeset(0): Modeline "1360x768"x60.0   72.00  1360 1408 1440 1520  768 771 781 790 +hsync -vsync (47.4 kHz d)
[     4.323] (II) modeset(0): Modeline "1152x864"x60.0   81.75  1152 1216 1336 1520  864 867 871 897 -hsync +vsync (53.8 kHz e)
[     4.323] (II) modeset(0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz d)
[     4.323] (II) modeset(0): Modeline "1024x768"x120.1  133.47  1024 1100 1212 1400  768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[     4.323] (II) modeset(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[     4.323] (II) modeset(0): Modeline "1024x768"x59.9   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync (47.8 kHz e)
[     4.323] (II) modeset(0): Modeline "960x720"x120.0  117.00  960 1024 1128 1300  720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[     4.323] (II) modeset(0): Modeline "928x696"x120.1  109.15  928 976 1088 1264  696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[     4.323] (II) modeset(0): Modeline "896x672"x120.0  102.40  896 960 1060 1224  672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[     4.323] (II) modeset(0): Modeline "960x600"x120.0   77.00  960 984 1000 1040  600 601 604 617 doublescan +hsync -vsync (74.0 kHz d)
[     4.323] (II) modeset(0): Modeline "960x540"x120.0   69.25  960 984 1000 1040  540 541 544 555 doublescan +hsync -vsync (66.6 kHz d)
[     4.323] (II) modeset(0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[     4.323] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[     4.323] (II) modeset(0): Modeline "800x600"x59.9   38.25  800 832 912 1024  600 603 607 624 -hsync +vsync (37.4 kHz e)
[     4.323] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[     4.323] (II) modeset(0): Modeline "840x525"x120.0   73.12  840 892 980 1120  525 526 529 544 doublescan -hsync +vsync (65.3 kHz d)
[     4.323] (II) modeset(0): Modeline "840x525"x119.8   59.50  840 864 880 920  525 526 529 540 doublescan +hsync -vsync (64.7 kHz d)
[     4.323] (II) modeset(0): Modeline "800x512"x120.3   51.56  800 800 828 832  512 512 514 515 doublescan +hsync +vsync (62.0 kHz d)
[     4.323] (II) modeset(0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[     4.323] (II) modeset(0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[     4.323] (II) modeset(0): Modeline "720x450"x119.8   53.25  720 760 836 952  450 451 454 467 doublescan -hsync +vsync (55.9 kHz d)
[     4.323] (II) modeset(0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[     4.323] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[     4.323] (II) modeset(0): Modeline "640x480"x59.4   23.75  640 664 720 800  480 483 487 500 -hsync +vsync (29.7 kHz e)
[     4.323] (II) modeset(0): Modeline "720x400"x59.6   22.25  720 744 808 896  400 403 413 417 -hsync +vsync (24.8 kHz e)
[     4.323] (II) modeset(0): Modeline "680x384"x119.6   42.38  680 716 784 888  384 385 390 399 doublescan -hsync +vsync (47.7 kHz d)
[     4.323] (II) modeset(0): Modeline "680x384"x119.9   36.00  680 704 720 760  384 385 390 395 doublescan +hsync -vsync (47.4 kHz d)
[     4.323] (II) modeset(0): Modeline "640x400"x60.0   20.00  640 664 720 800  400 403 409 417 -hsync +vsync (25.0 kHz e)
[     4.323] (II) modeset(0): Modeline "576x432"x120.1   40.81  576 608 668 760  432 432 434 447 doublescan -hsync +vsync (53.7 kHz d)
[     4.323] (II) modeset(0): Modeline "640x350"x59.8   17.50  640 664 720 800  350 353 363 366 -hsync +vsync (21.9 kHz e)
[     4.323] (II) modeset(0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[     4.323] (II) modeset(0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[     4.323] (II) modeset(0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[     4.323] (II) modeset(0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)

If you need any information just let me know.

Quite odd bug I had to say. First things first, does adding
Option “ModeValidation” “DP-0:AllowNonEdidModes”
to your /etc/X11/xorg.conf file give you more usable modelines?

Edid that drivers reads from the monitor differs a bit between the two:

346.22

$ parse-edid edid346.bin 
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

        # EDID version 1 revision 4
Section "Monitor"
        # Block type: 2:0 3:0
        # Block type: 2:0 3:fe
        # Block type: 2:0 3:fe
        Identifier "LGD:6904"
        VendorName "LGD"
        ModelName "LGD:6904"
        # Block type: 2:0 3:0
        # Block type: 2:0 3:fe
        # Block type: 2:0 3:fe
        # DPMS capabilities: Active off:no  Suspend:no  Standby:no

        Mode    "1920x1080"     # vfreq 75.002Hz, hfreq 83.327kHz
                DotClock        173.320000
                HTimings        1920 1968 2000 2080
                VTimings        1080 1083 1088 1111
                Flags   "-HSync" "+VSync"
        EndMode
        # Block type: 2:0 3:0
        # Block type: 2:0 3:fe
        # Block type: 2:0 3:fe
EndSection
$ edid-decode edid346.bin 
Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   30 e4 69 04 00 00 00 00 00 18
version:         01 04
basic params:    95 26 15 78 0a
chroma info:     0b b5 a3 59 55 a0 27 0c 50 54
established:     00 00 00
standard:        01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    b4 43 80 a0 70 38 1f 40 30 20 35 00 7e d7 10 00 00 1a
descriptor 2:    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
descriptor 3:    00 00 00 fe 00 4c 47 20 44 69 73 70 6c 61 79 0a 20 20
descriptor 4:    00 00 00 fe 00 4c 50 31 37 33 57 46 34 2d 53 50 46 31
extensions:      00
checksum:        3e

Manufacturer: LGD Model 469 Serial Number 0
Made week 0 of 2014
EDID version: 1.4
Digital display
6 bits per primary color channel
DisplayPort interface
Maximum image size: 38 cm x 21 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4, YCrCb 4:2:2
First detailed timing is preferred timing
Established timings supported:
Standard timings supported:
Detailed mode: Clock 173.320 MHz, 382 mm x 215 mm
               1920 1968 2000 2080 hborder 0
               1080 1083 1088 1111 vborder 0
               +hsync -vsync
Manufacturer-specified data, tag 0
ASCII string: LG Display
  ASCII string: LP173WF4-SPF1Checksum: 0x3e
EDID block does NOT conform to EDID 1.3!
        Missing name descriptor
        Missing monitor ranges

349.12

$ parse-edid edid349.bin 
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

        # EDID version 1 revision 4
Section "Monitor"
        # Block type: 2:0 3:0
        # Block type: 2:0 3:fe
        # Block type: 2:0 3:fe
        Identifier "LGD:6904"
        VendorName "LGD"
        ModelName "LGD:6904"
        # Block type: 2:0 3:0
        # Block type: 2:0 3:fe
        # Block type: 2:0 3:fe
        # DPMS capabilities: Active off:no  Suspend:no  Standby:no

        Mode    "1920x1080"     # vfreq 60.006Hz, hfreq 66.667kHz
                DotClock        138.000000
                HTimings        1920 1968 2000 2070
                VTimings        1080 1083 1088 1111
                Flags   "-HSync" "+VSync"
        EndMode
        # Block type: 2:0 3:0
        # Block type: 2:0 3:fe
        # Block type: 2:0 3:fe
EndSection
$ edid-decode edid349.bin 
Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   30 e4 69 04 00 00 00 00 00 18
version:         01 04
basic params:    95 26 15 78 0a
chroma info:     0b b5 a3 59 55 a0 27 0c 50 54
established:     00 00 00
standard:        01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    e8 35 80 96 70 38 1f 40 30 20 35 00 7e d7 10 00 00 1a
descriptor 2:    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
descriptor 3:    00 00 00 fe 00 4c 47 20 44 69 73 70 6c 61 79 0a 20 20
descriptor 4:    00 00 00 fe 00 4c 50 31 37 33 57 46 34 2d 53 50 46 31
extensions:      00
checksum:        22

Manufacturer: LGD Model 469 Serial Number 0
Made week 0 of 2014
EDID version: 1.4
Digital display
6 bits per primary color channel
DisplayPort interface
Maximum image size: 38 cm x 21 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4, YCrCb 4:2:2
First detailed timing is preferred timing
Established timings supported:
Standard timings supported:
Detailed mode: Clock 138.000 MHz, 382 mm x 215 mm
               1920 1968 2000 2070 hborder 0
               1080 1083 1088 1111 vborder 0
               +hsync -vsync
Manufacturer-specified data, tag 0
ASCII string: LG Display
  ASCII string: LP173WF4-SPF1Checksum: 0x22
EDID block does NOT conform to EDID 1.3!
        Missing name descriptor
        Missing monitor ranges

For short term solution, one could use that modeline or use custom edid constructed from 346.22 edid.

This seems to work, although I had to use the new pixel clock of 138.

For me these changes do not change a thing. My screen still flickers. In nvidia-settings i do not have more options or modes when i add Option “ModeValidation” “DP-0:AllowNonEdidModes” to my xorg.conf.
With ubuntu 15.04 and the default nouveau-driver i reached a reslolution of 1280x1080 without flickering screen but for some reasons i need the working nvidia-driver.

my section “monitor” looks like this now:

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “LGD”
HorizSync 66.0 - 66.0
VertRefresh 60.0
ModeLine “1920x1080” 173.320000 1920 1968 2000 2080 1080 1083 1088 1111 -hsync +vsync
Option “DPMS”
Option “ModeValidation” “DP-0:AllowNonEdidModes”
EndSection

But my problem still exists.

Hi guys,

Sorry for the delay. I contacted the “Linux bugs” support from Nvidia and after to find a solution, Arthur Huillet (from Nvidia) explained me that the Linux Nvidia driver does not find the correct EDID for the screen’s laptop.

This is the workaround that i found to fix the problem :

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
#    HorizSync       28.0 - 33.0
#    VertRefresh     43.0 - 72.0
    Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
    Modeline "1920x1080_75.00" 220.64 1920 2056 2264 2608 1080 1081 1084 1128 -HSync +Vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID "PCI:1:0:0"
    Option "IgnoreEdidChecksum" "DFP-1"
    Option "ModeValidation" "AllowNonEdidModes, NoHorizSyncCheck, NoVertRefreshCheck, NoMaxPClkCheck, NoEdidMaxPClkCheck, NoVesaModes, NoXServerModes, NoEdidModes"
    Option "MetaModes" "DFP-1: 1920x1080_75"
EndSection

Io, can you try my Xorg.conf’s options ?

Thanks,
Max

Yes! That workaround from OdelPasso works for me. Nice, thank you OdelPasso.
Anyway, i hope there will be a driver soon which recognizes the monitor correct.

Thanks guys!

Wow guys you are so great! You did it!

Here is my full xorg.conf (in case someone needs it):

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
#    HorizSync       28.0 - 33.0
#    VertRefresh     43.0 - 72.0
    Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
    Modeline "1920x1080_75.00" 220.64 1920 2056 2264 2608 1080 1081 1084 1128 -HSync +Vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID "PCI:1:0:0"
    Option "IgnoreEdidChecksum" "DFP-1"
    Option "ModeValidation" "AllowNonEdidModes, NoHorizSyncCheck, NoVertRefreshCheck, NoMaxPClkCheck, NoEdidMaxPClkCheck, NoVesaModes, NoXServerModes, NoEdidModes"
    Option "MetaModes" "DFP-1: 1920x1080_75"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Note: I’m using the 346.59 driver.

And yes I hope that future driver versions won’t need this hack anymore too.

I must add something, i dont have Linux(I have Windows 8.1), although i recently got a MSI GE72 2QF and it seems to want to run on my dedicated graphics instead of the graphics card 970m, and when i deactivate the integrated graphics driver it runs other games not even with 10 fps. And it doesnt run CS GO at all (Which i play the most).

So, it seems like its not only Linux users who has problems with this patch or laptop, or whatever…

Yes, i´ve tried reinstalling drivers etc.

Think you have better luck in the GeForce forums since this is Linux part of the woods also since you dont have the same issue a new thread would be appropriate.