980m on msi gt72s 4k uhd no mode setting with newest drivers

Hello!

I have a MSI GT72s with 4k UHD and 2x 128GB Nvme SSDs. It has a NVIDIA 980m with 8GB DDR5 RAM.
The nouveau variant works without problems. However, I would be glad to have the “right” NVIDIA drivers with 3D support at work.

I have on the first NVMEe Openmandriva 3.02, on the second Mageia 6RC and on the harddisk Win7 and Rosalinux R9, which is my main system. Since it can not be installed on the NVMe’s, I have move to OpenMandriva.

Long story short - on any of the three Linux systems, the Nvidia drivers can’t be installed correctly. With Win7 everything works great.

I’ve tried it first with the current drivers of openmandriva, and than using the Latest Short Lived Branch version: 381.22.

As far as I understand it, according to Xorg.0.log it also loads the driver, but can not set mods for the screen:

Here the relevant part:

[ 29.735] (II) LoadModule: “glx”
[ 29.735] (II) Loading /usr/lib64/xorg/extra-modules/libglx.so
[ 29.737] (II) Module glx: vendor=“NVIDIA Corporation”
[ 29.737] compiled for 4.0.2, module version = 1.0.0
[ 29.737] Module class: X.Org Server Extension
[ 29.737] (II) NVIDIA GLX Module 378.13 Tue Feb 7 18:25:34 PST 2017
[ 29.737] (II) LoadModule: “nvidia”
[ 29.737] (II) Loading /usr/lib64/xorg/extra-modules/nvidia_drv.so
[ 29.738] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 29.738] compiled for 4.0.2, module version = 1.0.0
[ 29.738] Module class: X.Org Video Driver
[ 29.738] (II) NVIDIA dlloader X Driver 378.13 Tue Feb 7 18:01:51 PST 2017
[ 29.738] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 29.738] (II) Loading sub module “fb”
[ 29.738] (II) LoadModule: “fb”
[ 29.738] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 29.738] (II) Module fb: vendor=“X.Org Foundation”
[ 29.738] compiled for 1.19.3, module version = 1.0.0
[ 29.738] ABI class: X.Org ANSI C Emulation, version 0.4
[ 29.738] (II) Loading sub module “wfb”
[ 29.738] (II) LoadModule: “wfb”
[ 29.738] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 29.738] (II) Module wfb: vendor=“X.Org Foundation”
[ 29.738] compiled for 1.19.3, module version = 1.0.0
[ 29.738] ABI class: X.Org ANSI C Emulation, version 0.4
[ 29.738] (II) Loading sub module “ramdac”
[ 29.738] (II) LoadModule: “ramdac”
[ 29.738] (II) Module “ramdac” already built-in
[ 29.739] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 29.739] (==) NVIDIA(0): RGB weight 888
[ 29.739] (==) NVIDIA(0): Default visual is TrueColor
[ 29.739] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 29.739] (
) NVIDIA(0): Option “RenderAccel” “false”
[ 29.739] () NVIDIA(0): Disabling RENDER acceleration
[ 29.739] (
) NVIDIA(0): Enabling 2D acceleration
[ 30.170] (–) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[ 30.170] (–) NVIDIA(0): DFP-0
[ 30.170] (–) NVIDIA(0): DFP-1 (boot)
[ 30.170] (–) NVIDIA(0): DFP-2
[ 30.170] (–) NVIDIA(0): DFP-3
[ 30.170] (–) NVIDIA(0): DFP-4
[ 30.170] (–) NVIDIA(0): DFP-5
[ 30.171] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 980M (GM204-A) at PCI:1:0:0 (GPU-0)
[ 30.171] (–) NVIDIA(0): Memory: 8388608 kBytes
[ 30.171] (–) NVIDIA(0): VideoBIOS: 84.04.48.00.29
[ 30.171] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 30.171] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 30.171] (–) NVIDIA(GPU-0): DFP-0: Internal TMDS
[ 30.171] (–) NVIDIA(GPU-0): DFP-0: 165.0 MHz maximum pixel clock
[ 30.171] (–) NVIDIA(GPU-0):
[ 30.171] (–) NVIDIA(GPU-0): AU Optronics Corporation (DFP-1): connected
[ 30.171] (–) NVIDIA(GPU-0): AU Optronics Corporation (DFP-1): Internal DisplayPort
[ 30.171] (–) NVIDIA(GPU-0): AU Optronics Corporation (DFP-1): 960.0 MHz maximum pixel clock
[ 30.171] (–) NVIDIA(GPU-0):
[ 30.171] (–) NVIDIA(GPU-0): DFP-2: disconnected
[ 30.171] (–) NVIDIA(GPU-0): DFP-2: Internal DisplayPort
[ 30.171] (–) NVIDIA(GPU-0): DFP-2: 960.0 MHz maximum pixel clock
[ 30.171] (–) NVIDIA(GPU-0):
[ 30.171] (–) NVIDIA(GPU-0): DFP-3: disconnected
[ 30.172] (–) NVIDIA(GPU-0): DFP-3: Internal TMDS
[ 30.172] (–) NVIDIA(GPU-0): DFP-3: 165.0 MHz maximum pixel clock
[ 30.172] (–) NVIDIA(GPU-0):
[ 30.172] (–) NVIDIA(GPU-0): DFP-4: disconnected
[ 30.172] (–) NVIDIA(GPU-0): DFP-4: Internal DisplayPort
[ 30.172] (–) NVIDIA(GPU-0): DFP-4: 960.0 MHz maximum pixel clock
[ 30.172] (–) NVIDIA(GPU-0):
[ 30.172] (–) NVIDIA(GPU-0): DFP-5: disconnected
[ 30.172] (–) NVIDIA(GPU-0): DFP-5: Internal TMDS
[ 30.172] (–) NVIDIA(GPU-0): DFP-5: 165.0 MHz maximum pixel clock
[ 30.172] (–) NVIDIA(GPU-0):
[ 30.172] (EE) NVIDIA(GPU-0): Unable to add conservative default mode “nvidia-auto-select”.
[ 30.172] (EE) NVIDIA(GPU-0): Unable to add “nvidia-auto-select” mode to ModePool.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:3840x2160”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:3200x1800”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:2880x1620”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:2560x1440”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:1920x1080”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:1600x900”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:1366x768”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:1360x765”; removing.
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:1280x720”; removing.
[ 30.172] (WW) NVIDIA(0):
[ 30.172] (WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
[ 30.172] (WW) NVIDIA(0): “nvidia-auto-select”.
[ 30.172] (WW) NVIDIA(0):
[ 30.172] (WW) NVIDIA(0): No valid modes for “DFP-1:nvidia-auto-select”; removing.
[ 30.172] (EE) NVIDIA(0): Unable to use default mode “nvidia-auto-select”.
[ 30.172] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 30.217] (II) UnloadModule: “nvidia”
[ 30.217] (II) UnloadSubModule: “wfb”
[ 30.217] (II) UnloadSubModule: “fb”
[ 30.217] (EE) Screen(s) found, but none have a usable configuration.
[ 30.217] (EE)
Fatal server error:
[ 30.217] (EE) no screens found(EE)
[ 30.217] (EE)

The output of xrandr:

Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
3840x2160 60.02*+
2048x1536 60.00
1920x1440 60.00
1856x1392 60.01
1792x1344 60.01
1920x1200 59.95
1920x1080 60.00
1600x1200 60.00 59.95
1680x1050 60.00
1400x1050 59.98 60.00
1280x1024 59.95 60.02
1280x960 60.00 59.99
1152x864 59.97
1024x768 60.04 60.00 59.95
960x720 60.00
928x696 60.05
896x672 60.01
800x600 60.00 60.32 59.96 56.25
700x525 59.98
640x512 60.02
640x480 60.00 59.94 59.94
720x400 59.97
640x400 59.96
640x350 59.84
512x384 60.00
400x300 60.32 56.34
320x240 60.05
HDMI-1 disconnected (normal left inverted right x axis y axis)

Best regards,

Tomas

Additional information:

This is not an Optimus problem, because the graphics card can be manually switched by the push of a special button.

Please run nvidia-bug-report.sh and attach output file to post. Or at least post your xorg.conf. Why are you disabling RenderAccel?

Hello, thank you for quick response!

The xconf.org file was automatical created by the systemtool for graphics - so it’s disabling RenderAccel.

I also create a file in /ext/X11/xorg.conf.d/ called 10-nvidia.conf:

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BusID “PCI:1:0:0”
EndSection

Best regards,

Tomas
xorg.conf.txt (10 KB)

That xorg.conf is utter BS. Use nvidia-xconfig to generate a better one or set up a minimal one by hand.

Hello,

thank you for your tip. I try it out but anyway get a black flickering screen as usual.

I attached the new Xorg.conf and the Xorg.0.log

I find one site in on which the problem is described a bit more: https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Screen.28s.29_found.2C_but_none_have_a_usable_configuration

but unfortunately no concrete solution…

/Screen(s) found, but none have a usable configuration

/Sometimes NVIDIA and X have trouble finding the active screen. If your graphics card has multiple /outputs try plugging your monitor into the other ones. On a laptop it may be because your graphics /card has vga/tv outs. Xorg.0.log will provide more info.

/Another thing to try is adding invalid “ConnectedMonitor” Option to Section “Device” to force Xorg /throws error and shows you how correct it. Here more about ConnectedMonitor setting. (ftp://download.nvidia.com/XFree86/Linux-x86/355.11/README/xconfigoptions.html) <-- it’s offline

/After re-run X see Xorg.0.log to get valid CRT-x,DFP-x,TV-x values.

/nvidia-xconfig --query-gpu-info could be helpful.

xorg.conf.txt (3.94 KB)
Xorg.0.log.txt (8.49 KB)

Please add

Option "ModeDebug" "true"
Option "ConnectedMonitor" "DFP-1"

to the device section of your xorg.conf and post a new xorg log afterwards.

I done it and get the following log…
Xorg.0.log.txt (8.49 KB)

I don’t know where you added this but it has no effect. There should be a line (**) NVIDIA(0): Option “ModeDebug” in the logs if done right.

I added like this:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “NVIDIA GeForce 420 series and later”
Option “ModeDebug” “true”
Option “ConnectedMonitor” “DFP-1”
EndSection

You have two ‘Device0’ sections, probably one in a file in /etc/X11/xorg.conf.d
Remove that, retry.

your right, there was a file 10-nvidia.conf.

Now we get informations :)

Xorg.0.log.txt (128 KB)

Looks like some kind of driver bug. Please comment out the extra Modelines in xorg.conf and add

Option "ModeValidation" "NoExtendedGpuCapabilitiesCheck"

to the device section, retry.

Strike, that’s it! Now for the first time since two weeks, since I buy my Laptop it works!
Thank you!!!

But for now it’s only UHD, 3840x2140, is there a Way to activate the other resolutions too? I would be happy with 1920x1080 or 1920x1200. Because for working on texts or graphics it’s a much better resolution…

Best regards,

Tomas

Xorg.0.log.txt (162 KB)

Since your display doesn’t support scaling you will have to set up metamodes, adding something like

Option    "Metamodes" "DFP-1: nvidia-auto-select; nvidia-auto-select {ViewPortIn=1920x1080}; nvidia-auto-select {ViewPortIn=1920x1200}"

to the screen section.
Edit: you can also use the Option “IncludeImplicitMetaModes”
See this for details: http://us.download.nvidia.com/XFree86/Linux-x86/346.47/README/xconfigoptions.html

The first option you propose me unfortunately not working.

I edit the lines like this:

Section “Screen”
Identifier “screen0”
Device “Device0”
Monitor “monitor0”
DefaultDepth 24
Option “DPMS”
Option “Metamodes” “DFP-1: nvidia-auto-select; nvidia-auto-select {ViewPortIn=1920x1080}; nvidia-auto-select {ViewPortIn=1920x1200}”

SubSection “Display”
Depth 15
Modes “3840x2160” “1920x1080” “1920x1200”
EndSubSection
SubSection “Display”
Depth 16
Modes “3840x2160” “1920x1080” “1920x1200”
EndSubSection

SubSection     "Display"
    Depth       8
    Modes      "3840x2160" "1920x1080" "1920x1200"
EndSubSection
SubSection     "Display"
    Depth       24
    Modes      "3840x2160" "1920x1080" "1920x1200"
EndSubSection

EndSection

I will try “IncludeImplicitMetaModes” now.
Xorg.0.log.txt (151 KB)
nvidia-bug-report.log.gz (277 KB)

The log said it’s already setting up implicit metamodes.
What’s the output of xrandr and xrandr --q1 ?

[    97.120] (II) NVIDIA(0): Validated MetaModes:
[    97.120] (II) NVIDIA(0): Virtual screen size determined to be 3840 x 2160
[    97.121] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 2560 x 1600, ViewPortOut = 3456 x 2160 + 192 + 0 }"
[    97.121] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 2560 x 1440, ViewPortOut = 3840 x 2160 + 0 + 0 }"
[    97.121] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1680 x 1050, ViewPortOut = 3456 x 2160 + 192 + 0 }"
[    97.122] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1600 x 1200, ViewPortOut = 2880 x 2160 + 480 + 0 }"
[    97.122] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1440 x 900, ViewPortOut = 3456 x 2160 + 192 + 0 }"
[    97.122] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1366 x 768, ViewPortOut = 3840 x 2158 + 0 + 1 }"
[    97.122] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1280 x 1024, ViewPortOut = 2700 x 2160 + 570 + 0 }"
[    97.122] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1280 x 800, ViewPortOut = 3456 x 2160 + 192 + 0 }"
[    97.122] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1280 x 720, ViewPortOut = 3840 x 2160 + 0 + 0 }"
[    97.123] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 1024 x 768, ViewPortOut = 2880 x 2160 + 480 + 0 }"
[    97.123] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 800 x 600, ViewPortOut = 2880 x 2160 + 480 + 0 }"
[    97.123] (II) NVIDIA(0): Adding implicit MetaMode: "DP-0: nvidia-auto-select { ViewPortIn = 640 x 480, ViewPortOut = 2880 x 2160 + 480 + 0 }"

Edit: maybe just delete the Option “Metamodes” line, it’s set up automatically anyway. Are those metamodes useable in nvidia-settings?

With the other method it’s also not working.
The output of xrandr:

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
3840x2160 60.02*+
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)

xrandr -q

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
3840x2160 60.02*+
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)

instead of with nouveau driver:
xrandr

Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 16384 x 16384
LVDS-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DVI-D-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DVI-D-2 disconnected (normal left inverted right x axis y axis)
eDP-1 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 382mm x 214mm
3840x2160 60.02 +
1920x1200 59.88*
1920x1080 59.96
1600x1200 59.87
1680x1050 59.95
1400x1050 59.98
1280x1024 59.89
1280x960 59.94
1152x864 59.96
1024x768 59.92
800x600 59.86
640x480 59.38
720x400 59.55
640x400 59.95
640x350 59.77
DP-3 disconnected (normal left inverted right x axis y axis)
VGA-1 disconnected (normal left inverted right x axis y axis)

Edit: Without option Metamodes line I get same result. Still not working.

Can you see them in nvidia-settings?

As workaround, you can use scaling:
xrandr --output DP-0 --scale 2x2

Yes, with nvidia-settings it’s possible to see them - there is behind each line (scaling)
I try to make a new xorg.conf with the program, but still get the black flickering screen.

xrandr --output DP-0 --scale 2x2 gets:

warning: output DP-0 not found; ignoring

I attached the nvidia-settings xorg.conf
xorg.conf.txt (2.01 KB)