Unable to enable hdmi on jetson orin Nano for custom carrier board Jetpack 5.1.2

Xor_0_log .txt (25.5 KB)

We have designed the custom carrier board taking as a reference the Jetson Orin Nano’s dev kit reference carrier board (P3768-0000) schematics.
Our Custom carrier board’s main differences with respect to reference carrier board (P3768-0000)
• Doesn’t have EEPROM.
• HDMI port instead of DP
As the Orin Nano, is configured for DP out of the box ,I have tried to enable the HDMI (flashing the board with Jetpack5.1.2 with sdk manager.
Later i modified the hdmi relevant changes and reflashed the module(initrd) to check with custom board ,i still see the hdmi port is disconnected in startx . one strange thing is i saw was even though the kernel dtb has the hotplug port part included and checking the /proc/device-tree/ has the hotplug configrured ,but in the /sys/kernel/debug/gpio i see the hpd relevant gpio pin not enabled.I enable the gpio and set it as input from uart terminal .but still no screen.i am attaching the xxorg.0.log and relevant snippets fromt he uart terminal .

MicrosoftTeams-image (44)

Could you please let me know how can i ensure the hotplug GPIO is taken in to consideration and is workign properly.

Thank you

/sys/kernel/debug/gpio won’t see that pin. It is normal behavior.

If there is no log printed from uart console when you hotplug the cable, check the pinmux setting of the hotplug pin.

Thank you

I have used the hdmi pinmux file (verified the hdmi pins are sames are our schematics)
tegra234-mb1-bct-pinmux-p3767-hdmi-a03.dtsi (65.8 KB)

if i understand correctly you mean to check this part right ?

Also a small question :
I have read soemwhere in the forum that Display SW needs to be updated in both QSPI and additional storage(if thats true does doing initrd flash is enough?,how can i check that everythign is udpated ?)

I have followed documentation to exceute the changes ,but i am quite new to the embedded linux ,so any help or guidance on this is much appreciatied.


Actually you can just directly flash your board with p3509+p3767 config. It will have all the software patches working.

You can try to share the flash command and log.

Thank you :-) .I will do it right away .Just to be sure ,i have th following config files.
Screenshot from 2024-04-04 14-38-55

WIll execute the below command :

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device mmcblk1p1
-c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml”
–showlogs --network usb0 p3509-a02+p3767-0000.conf internal

Are you using a orin nano sdcard module on a custom board?

Do you have the commercial module to test here with nvme drive?

Yes, i have Jetson orin nano dev kit iwth sd card slot .I am flashing the orin nano sdcard module with its carrier board in force recovery mode .and then placing the orin nano sdcard module on our custom carrier board to check

Ok. It sounds a weird test environment.

Please do the flash with that command.

Hi ,I have flashed the board .I still donot see a screen.
flash_1-2_0_20240404-152401.log (41.5 KB)
i am sharing the Xorg log here
x_org_after_flash.txt (30.1 KB)

Do you have the dmesg to share?

BTW, your flash log looks abnormal too. Could you also share the command you are really typing on the terminal along with your log?
There is no flash attempt to the QSPI in your log.

I mean I shall see them all in just one file.

Hi, Yes i can share the dmesg here.
dmesg.txt (137.2 KB)
Yes I have the flash log from host terminal saved too.
flash_terminal.txt (306.0 KB)
Thank you

Just to clarify.

  1. So what did you share to us in previous comment?
    Previous log does not help at all…

  2. Your dmesg is incomplete. Please directly share your boot up log from uart serial console. If you don’t know what I mean, please tell.

Hi ,
Soryy for the previous comment,i didnt explain clearly.I have logged the “dmesg.txt” from uart serial console after the boot up ,as i dont have a screen.
“flash_terminal.txt” is the terminal copy of the flash command and logs on the host pc.
Please find below boot up log from uart console.(sorry the first 50 lines are gibberish on the uart log,after line 900 ,there’s direct boot log )
boot_log_uart.txt (98.8 KB)

One question, so when you hotplug the HDMI cable, will you see anything printed out from uart console?

Hi ,Yes i checked if there is anything printed on the uart console .It doesnt print anything .

Then how did you get such log in your previous message if UART log does not print anything when you hotplug HDMI cable?

Under which situation?

[   35.597467] pstate: 20400089 (nzCv daIf +PAN -UAO -TCO BTYPE=--)
[   35.597469] pc : tegra186_gpio_irq+0x1ac/0x1f0
[   35.597471] lr : tegra186_gpio_irq+0x11c/0x1f0
[   35.597473] sp : ffff800010003c60
[   35.597474] x29: ffff800010003c60 x28: ffff1eaf00daa460
[   35.597477] x27: ffffdd9dcfbecff8 x26: 0000000000000018
[   35.597480] x25: ffff1eaf05425880 x24: ffff1eaf0543b000
[   35.597483] x23: 000000000000000c x22: 000000000000004c
[   35.597486] x21: 00000000000000af x20: 0000000000000000
[   35.597489] x19: ffffdd9dcf09ee50 x18: 0000000000000000
[   35.597491] x17: 0000000000000000 x16: ffffdd9dcefb5db0
[   35.597494] x15: 0000000000000000 x14: 0000000000000000
[   35.597497] x13: 0000000000000003 x12: 0000000000000500
[   35.597500] x11: 0000000000000040 x10: ffffdd9dcfb57a80
[   35.597503] x9 : ffffdd9dcfb57a78 x8 : ffff1eaf004b1020
[   35.597505] x7 : 0000000000000000 x6 : 0000000000000001
[   35.597508] x5 : 0000000000000000 x4 : 0000000000000000
[   35.597511] x3 : 0000000000000000 x2 : ffffdd9dcdf6e170
[   35.597514] x1 : 000000000000004c x0 : 0000000000000000
[   35.597516] Call trace:
[   35.597518]  tegra186_gpio_irq+0x1ac/0x1f0
[   35.597521]  generic_handle_irq+0x40/0x60
[   35.597523]  __handle_domain_irq+0x70/0xd0
[   35.597525]  gic_handle_irq+0x68/0x134

The above log that you shared is from “dmesg.txt” , please correct me if i am wrong .

The hdmi cable is already connected to the board ,i powered up and logged the dmesg .
I noticed the message was repeatedly printing .Could you please let me know what can i infer from this log,just to understand.

Thank you

  1. That tegra186_gpio_irq is a normal behavior that should show up when you hotplug the HDMI cable to your board.
    That was why I am asking the scenario you saw such log.

  2. Are you saying that you can see that log only in the beginning of boot but it won’t trigger again when you hotplug the cable?