Unable to get driver 418.43 for archlinux to load

I have recently just purchased an alienware m15, unfortunatly I have been unable to get the nvidia driver to load under arch?

I suspect the the rtx 2060 isn’t supported as of the 418.43 driver for linux?

I have linked the nvidia report and some extra information as well, any help is appreciated :)
nvidia-bug-report.log.gz (56.4 KB)
lspci.log (2.95 KB)
lsmod.log (7.68 KB)
journalctl.log (313 KB)
dmesg.log (4.72 KB)

The download link requires registration. Attaching files:
Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Thanks for the tip, I have attached the necessary file to the original post as mentioned.

Please remove the kernel parameter acpi=noirq and create a new nvidi-bug-report.log.

I am unable to regenerate a bug report, with that parameter removed as the machine hangs while booting without it?

Sorry if this isn’t helpful.

Please try with kernel parameter
pci=biosirq

I gave it a shot, but seems to have made no difference.
nvidia-bug-report.log.gz (57.1 KB)

Does the notebook boot if you exchange
acpi=noirq
with
acpi_osi=! acpi_osi=“Windows 2009”

I have given this parameter ago and haven’t be able to get the machine to post by replacing acpi=noirq.

I also tried a few other option like, acpi_osi=“Windows” and acpi_osi=“Windows 2015”, but still wasn’t able to get the machine to post.

I did an update today as well, and it seems to throw some more errors in dmesg and journalctl. I will post logs in a bit

Cheers nickobelic1999 :)

As a matter of fact, as long as you’re using the acpi=noirq parameter, the nvidia gpu will not work as it doesn’t get an irq (alongside many other devices).
When you remove it, what’s the last lines of the kernel messages displayed (maybe take a photo)?
Please run
sudo acpidump>acpidump.txt
and attach that.

Hello,

I have been busy with work over the past couple of days and unable to continue testing this issuse. But I managed to get some testing in this morning and tried a few other acpi related parameters as shown in the ubuntu wiki: https://wiki.ubuntu.com/DebuggingACPI

I managed to get the machine to get to the desktop with the “noapic” kernel parameter.

It seems as if the the laptop is working now, and I can launch the nvidia xorg server setting application.

I ran a few benchmarks and noticed the GPU was only running at 260Mhz under a blender benchmark load, is this normal for this?

Cheers nickobelic1999 :)

You probably just ran blender in cpu mode, gpu mode would require a cuda install and setting the appropriate options.