Arch linux problems with GeForce 8600M GT

My system:
Processor 2.4 GHz Intel Core 2 Duo
Memory 4 GB 667 MHz DDR2 SDRAM
Graphics NVIDIA GeForce 8600M GT 256 MB

archlinux-2013.09.01-dual

uname -rs
Linux 3.11.2-1-ARCH

At first i tried to install nvidia driver through pacman

and a had

NVRM: failed to copy vbios to system memory.

I tried to install NVIDIA-Linux-x86_64-319.17 from Nvidia web site
and i had:

include/linux/compiler.h:152:40: note: in definition of macro ‘likely’
    # define likely(x) __builtin_expect(!!(x), 1)
                                           ^
   /tmp/selfgz494/NVIDIA-Linux-x86_64-319.17/kernel/nv-i2c.c: In function ‘nv_i2c_del_adapter’:
   /tmp/selfgz494/NVIDIA-Linux-x86_64-319.17/kernel/nv-i2c.c:327:14: error: void value not ignored as it ought to be
        osstatus = i2c_del_adapter(pI2cAdapter);
                 ^
   make[3]: *** [/tmp/selfgz494/NVIDIA-Linux-x86_64-319.17/kernel/nv-i2c.o] Error 1
   make[2]: *** [_module_/tmp/selfgz494/NVIDIA-Linux-x86_64-319.17/kernel] Error 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Error 1
   make: *** [module] Error 2
-> Error.

Then i tried to install NVIDIA-Linux-x86_64-319.60 from Nvidia web site
and:

num_physpages’ undeclared (first use in this function)

i fixed it with https://devtalk.nvidia.com/default/topic/602829/-solved-nvidia-linux-3-11-compatibility-error-lsquo-num_physpages-rsquo-undeclared-first-use-i

and after reboot i have black screen again
if i do startx i have

[   76.676829] NVRM: failed to copy vbios to system memory.
[   76.677001] NVRM: RmInitAdapter failed! (0x30:0xffffffff:711)
[   76.677008] NVRM: rm_init_adapter(0) failed

Any help?

after some magic
i found this

nv_acpi_rom_method: failed to evaluate _ROM method!

may be this bug related to https://bugzilla.kernel.org/show_bug.cgi?id=42696