GeForce 8600M GT not supported by the latest NVIDIA drivers on (X)ubuntu


I have a rather old laptop Roverbook Nautilus V572 (actually the same as more widely known MSI GX-600) with GeForce 8600M GT installed. Despite the claims on driver site that this video card is still supported by the latest drivers it is not the case. Looks like nobody cares about such an old chipset as after upgrade to Xubuntu 14.04 even nouveau drives stopped to work. Is there any chance that it will be sometimes really supported by NVIDIA?

tried NVIDIA drivers 304 and 331 (packages nvidia-current and nvidia-331 of ubuntu Trusty version): drivers are failed to load with the follwoing error:
[ 18.358723] NVRM: RmInitAdapter failed! (0x26:0xffffffff:1200)
[ 18.358733] NVRM: rm_init_adapter(0) failed

tried legacy diver (package nvidia-173) and it actually works! but not completely: xserver constantly eats about 15% CPU and interface regularly freezes, so it is almost impossible to watch video

I know from “known problems description” that error messages like above means problem with BIOS reading and there are claims that it is impossible to solve such problems, but NVIDIA 173 drivers somehow able to read such info, so the problem may be somewhere else. So is there any chance to get my videocard working with latest xubuntu?

Attached files are
nvidia-bug-report-304.log.gz - failed boot with nvidia package (v304 drivers)
nvidia-bug-report-331.log.gz - failed boot with nvidia-331 package (v331 drivers)
nvidia-bug-report.log.gz - successful boot but problematic work with nvidia-173 package (v173 drivers)

[This file was removed because it was flagged as potentially malicious] (56 KB)
[This file was removed because it was flagged as potentially malicious] (59.7 KB)
nvidia-bug-report.log.gz (53.1 KB)

Your vbios isn’t copied to system

[   16.533274] NVRM: failed to copy vbios to system memory.
[   16.533590] NVRM: RmInitAdapter failed! (0x30:0xffffffff:720)
[   16.533599] NVRM: rm_init_adapter failed for device bearing minor number 0
[   16.533624] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5
*** /proc/driver/nvidia/./gpus/0/information
*** ls: -r--r--r-- 1 root root 0 2014-06-06 15:00:39.290426230 +0400 /proc/driver/nvidia/./gpus/0/information
Model: 		 GeForce 8600M GT
IRQ:   		 48
GPU UUID: 	 GPU-????????-????-????-????-????????????
Video BIOS: 	 ??.??.??.??.??
Bus Type: 	 PCIe
DMA Size: 	 32 bits
DMA Mask: 	 0xffffffff
Bus Location: 	 0000:01.00.0

Thank you for fast reply, but

  1. README talks about Optimus problems. AFAIK it is about switching between different video chips, isn’t it? I do have only GeForce 8600M onboard
  2. why 173 driver is capable of such reading, while 304 and 331 do not have such ability? Isn’t this a bug? two years ago no NVIDIA drivers worked for me, even legacy, now only laggy 173 supports me. Isn’t that a bug in drivers or just incorrect statement that 8600M is supported by the latest driver?
  3. could you please point me where I can read about “proper cooperation of ACPI and the System BIOS to retrieve important information about the GPU”? looks like I have to solve this problem by myself