[337.12 Beta] - GM107M [GeForce GTX 860M] - (EE) No devices detected

Seems I can’t get the 337.12 Beta Drivers to detect the GTX 860 in my new Laptop.
All I get in the X.org.0.log File is this:

[ 874.903] (II) LoadModule: “nvidia”
[ 874.903] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 874.903] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 874.903] compiled for 4.0.2, module version = 1.0.0
[ 874.903] Module class: X.Org Video Driver
[ 874.903] (II) NVIDIA dlloader X Driver 337.12 Fri Apr 4 14:13:45 PDT 2014
[ 874.903] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 874.903] (++) using VT number 2

[ 874.905] (EE) No devices detected.
[ 874.905] (EE)
Fatal server error:
[ 874.905] (EE) no screens found(EE)
[ 874.905] (EE)

From my understanding the GTX 860M should be supported by the latest Beta drivers (337.12). But from the Server Logfile it looks like the card is not detected at all.

Any Idea what might be goibg wrong ?

nvidia-bug-report.log.gz (126 KB)

Heyyo,

Hmm I’ve always found the geforce.com website sometimes improperly lists drivers… try the latest beta from nvidia.com … 331.67…

http://www.nvidia.com/download/driverResults.aspx/75019/en-us

This one should definitely support your GTX 860M.

Sure it is, but 860M sounds like Optimus, so read the driver-docu.

You know 337.12 is higher than 331.67?
And btw, 331.67 is not a beta driver!

Yes, the OP report is definitely an Optimus issue, OP has to use xrandr correctly or bumblebee assuming it works on the newer Maxwell cards without (much) issue. In ThE_MarD’s defense, just because a driver version is higher does not mean it’s the latest (datewise, at least). That being said, support for newer GPUs tends to happen in beta drivers before stable drivers, so that’s why a stable driver might be ‘newer’ than a beta driver.

337.12 BETA:

  • GeForce 800M Series (Notebooks): GeForce GTX 880M, GeForce GTX 870M, GeForce GTX 860M, GeForce GTX 850M, GeForce 840M, GeForce 830M, GeForce 820M

I don’t think the driver is the problem here.

Was/Is an optimus issue. Thanks to towo for pointing this out.
Bumblebee works now but i still have some primus issues.
I also noticed, that the latest stable drive 331.67 already supports the GTX 860M

Thanks to all for the support.

Heyyo,

Ack… yeah I meant long-lived not latest beta that was a brain fart lol… :P

I should have just referenced this thread:
https://devtalk.nvidia.com/default/topic/533434/linux/current-graphics-driver-releases/

on my GT 650M? 337.12 beta (using xorg-edgers ppa or the nVidia .run to install btw) gives me nvidia-prime issues as well, yet using the long-lived works great with nvidia-prime. 334.18 (I think that’s the one Ubuntu 14.04 shows in “additional drivers”) works as well. I haven’t tried 334.21

Hello all,

I am seeing the exact same symptoms as the OP with GTX 860M on Fedora. I cannot get the OS to recognize my GTX 860M as a VGA device - it only shows up as a 3D controller. I tried installing bumblebee - that makes no difference either.

Can anyone shed some light on this issue please? Thanks.

I should also have mentioned that I have tried the following drivers

  • 340.24
  • 337.19 - beta
  • 331.89

I have installed the drivers both directly (using nvidia install script) and also using rpmfusion.