Unable tu use Nvidia graphics on Arch with dual GPU

Hello, I tried to use NVIDIA graphics on my Linux laptop which has NVIDIA GeForce GTX 1050M + Intel HD Graphics 630. For my convenience I use optimus-manager (from AUR) to switch graphics, yet the symptoms described below also appear without it being installed.

I have installed the latest version of NVIDIA drivers (extra/nvidia-lts 1:495.44-19) on kernel 5.10.84-1-lts. My system boots just fine running on Intel graphics, however it is unable to do anything with NVIDIA graphics. When I try booting on NVIDIA (using optimus.manager’s kernel parameter supplied in GRUB), I can’t get into a Gnome and I’m stuck with a black screen. When I run nvidia-smi, it says that no devices were found, however both neofetch and lspci are able to detect it.

❯ lspci | grep NVIDIA
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

The issue can be seen when I run dmesg, it starts at line 9350 in my bug report file. Most notable, this message appears hundreds of times:

NVRM: GPU 0000:01:00.0: RmInitAdapter failed! (0x31:0xffff:2449)
NVRM: GPU 0000:01:00.0: rm_init_adapter failed, device minor number 0

I was able tu use my GPU before and the problems have started after I switched to POP_OS, however I am unable to install it again because the installer fails. I also had issues with installing Manjaro and Arch was the only distro I managed to get running.

Do you have any ideas on what would allow me to use my GPU again?

Thanks in advance.

nvidia-bug-report.log (1.4 MB)

I guess it’s simply broken, please double-check installing Windows.