NVidia-smi: No devices Found

Hi! I have a 1050 GPU on Ubuntu 16.04. Most of the solutions given here do not work for me. I have tried different driver version with no luck. I would like to know if this is indeed a GPU hardware issue. Attaching the logs here

lspci -v | grep VGA
02:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] (rev a1) (prog-if 00 [VGA controller])

No devices were found

dmesg|grep NVRM

[ 61.622257] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 440.59 Thu Jan 30 01:00:41 UTC 2020
[ 87.148483] NVRM: GPU 0000:02:00.0: RmInitAdapter failed! (0x25:0x65:1199)
[ 87.148510] NVRM: GPU 0000:02:00.0: rm_init_adapter failed, device minor number 0
[ 92.475476] NVRM: GPU 0000:02:00.0: RmInitAdapter failed! (0x25:0x65:1199)
same error again and again in a loop

Attached bug logs:
nvidia-bug-report.log.gz (536.4 KB)

This looks like a broken gpu. Already tried to reseat the card in the slot (pul it out - plug it back in)?

unfortunately the gpu isn’t accessible easily. I am trying to exhaust all options before having to remove a bunch of things to get access to it. Is there anything else that makes you certain that it is a hardware issue?

Thanks a lot for your help and guidance.