Unable to install Nvidia-Linux_x86-64-375.66 driver for CentOS server running Tesla K80s [GK210L] without breaking GUI on reboot

Good day,

I am running CentOS 7.2. I want to install Nvidia drivers for some Tesla cards so that I may be able to make use of CudNN libraries. These cards are relied on for display.

The system’s GUI crashes on reboot before the system takes me to the logon screen. Searching on the internet reveal that other’s have had this similar issue. I have tried a number of methods and third party packeages to prepare my system for install but they have not worked as well. I have removed Nouveau. I have tried installing the driver without the kernel. I have tried getting Elrepo. Getting crash reports is a not possible after the system has crashed on reboot.

Any advice?

What do you mean by this:

" These cards are relied on for display. "

Do you mean the Tesla cards are relied on for display? How so?

A typo, apologies.

I meant “Aren’t relied on for display”. They are just for GPGPU apps

Restore your system to the state where the display is working as you wish and the NVIDIA Driver is not installed.

Then, when you run the driver installer (I assume you are using a runfile driver installer for 375.66) you should specify the option --no-opengl-libs (or it may be --no-opengl-files but I believe that is for the CUDA toolkit installer).

If you are unsure of the option above, please run the driver installer with the --help command line switch. Then specify the command line switch to get advanced options (-A ? not sure), then in the list of advanced options, you should see the --no-opengl-libs option.