Unable to install nvidia-sym, No matching distribution found for vtk==9.1.0

I have been following: GitHub - NVIDIA/modulus-sym: An abstracted framework for training AI surrogates of physical systems using physics-based symbolic loss functions for installing the same, but vtk is giving me issues. I even tried with uninstalling but still no luck, below is the log for the same.

Thank you

Defaulting to user installation because normal site-packages is not writeable
Collecting nvidia-modulus-sym
  Using cached nvidia_modulus.sym-1.0.0-py3-none-any.whl (304 kB)
Collecting nvidia-modulus>=0.1.0 (from nvidia-modulus-sym)
  Using cached nvidia_modulus-0.1.0-py3-none-any.whl (167 kB)
Collecting hydra-core>=1.2.0 (from nvidia-modulus-sym)
  Using cached hydra_core-1.3.2-py3-none-any.whl (154 kB)
Requirement already satisfied: termcolor>=2.1.1 in /usr/local/lib/python3.10/dist-packages (from nvidia-modulus-sym) (2.3.0)
Requirement already satisfied: chaospy>=4.3.7 in ./.local/lib/python3.10/site-packages (from nvidia-modulus-sym) (4.3.13)
Requirement already satisfied: Cython==0.29.28 in /usr/lib/python3/dist-packages (from nvidia-modulus-sym) (0.29.28)
Requirement already satisfied: numpy-stl==2.16.3 in ./.local/lib/python3.10/site-packages (from nvidia-modulus-sym) (2.16.3)
Collecting opencv-python== (from nvidia-modulus-sym)
  Using cached opencv_python- (60.5 MB)
Collecting scikit-learn==1.0.2 (from nvidia-modulus-sym)
  Using cached scikit_learn-1.0.2-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (26.5 MB)
Collecting symengine==0.6.1 (from nvidia-modulus-sym)
  Using cached symengine-0.6.1.tar.gz (721 kB)
  Preparing metadata (setup.py) ... done
Requirement already satisfied: sympy==1.5.1 in /usr/local/lib/python3.10/dist-packages (from nvidia-modulus-sym) (1.5.1)
Collecting timm==0.5.4 (from nvidia-modulus-sym)
  Using cached timm-0.5.4-py3-none-any.whl (431 kB)
Requirement already satisfied: torch-optimizer==0.3.0 in ./.local/lib/python3.10/site-packages (from nvidia-modulus-sym) (0.3.0)
Collecting transforms3d==0.3.1 (from nvidia-modulus-sym)
  Using cached transforms3d-0.3.1.tar.gz (62 kB)
  Preparing metadata (setup.py) ... done
Requirement already satisfied: typing== in /usr/local/lib/python3.10/dist-packages (from nvidia-modulus-sym) (
INFO: pip is looking at multiple versions of nvidia-modulus-sym to determine which version is compatible with other requirements. This could take a while.
ERROR: Could not find a version that satisfies the requirement vtk==9.1.0 (from nvidia-modulus-sym) (from versions: 9.2.2, 9.2.4, 9.2.5, 9.2.6)
ERROR: No matching distribution found for vtk==9.1.0

Should I edit the project.toml file inorder to suffice the versions? but would that be safe to do so?

Even doing so has lead to the following error:

Building wheels for collected packages: nvidia-modulus.sym, symengine
  Building wheel for nvidia-modulus.sym (pyproject.toml) ... done
  Created wheel for nvidia-modulus.sym: filename=nvidia_modulus.sym-1.0.0-py3-none-any.whl size=305175 sha256=6d5367a9ec3d5757bf00ce3af8a98075acf099da93b306b386b5381839559a28
  Stored in directory: /home/neo11/.cache/pip/wheels/01/54/5e/971866f9c7424a705811f87cf308f47f204005ede35286ed6d
  Building wheel for symengine (setup.py) ... error
  error: subprocess-exited-with-error
  × python setup.py bdist_wheel did not run successfully.
  │ exit code: 1
  ╰─> [38 lines of output]
      running bdist_wheel
      running build
      running build_ext
      CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required):
        Compatibility with CMake < 2.8.12 will be removed from a future version of
        Update the VERSION argument <min> value or use a ...<max> suffix to tell
        CMake that the project does not need compatibility with older versions.
      -- The C compiler identification is GNU 11.3.0
      -- The CXX compiler identification is GNU 11.3.0
      -- Detecting C compiler ABI info
      -- Detecting C compiler ABI info - done
      -- Check for working C compiler: /usr/bin/cc - skipped
      -- Detecting C compile features
      -- Detecting C compile features - done
      -- Detecting CXX compiler ABI info
      -- Detecting CXX compiler ABI info - done
      -- Check for working CXX compiler: /usr/bin/c++ - skipped
      -- Detecting CXX compile features
      -- Detecting CXX compile features - done
      CMake Error at CMakeLists.txt:5 (find_package):
        Could not find a package configuration file provided by "SymEngine"
        (requested version 0.6.0) with any of the following names:
        Add the installation prefix of "SymEngine" to CMAKE_PREFIX_PATH or set
        "SymEngine_DIR" to a directory containing one of the above files.  If
        "SymEngine" provides a separate development package or SDK, be sure it has
        been installed.
      -- Configuring incomplete, errors occurred!
      error: error calling cmake
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for symengine
  Running setup.py clean for symengine
Successfully built nvidia-modulus.sym
Failed to build symengine
ERROR: Could not build wheels for symengine, which is required to install pyproject.toml-based projects

Hi @nihalpushkar11

This is likely because your Python version is too new (e.g. >=3.10), try downgrading your python version to say 3.8 and trying. The VTK dependency in Modulus sym doesn’t support newer python versions. We are tracking this issue to fix.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.