Unable to install TensorRT for python 3.8.12

Hi All,

I am trying to install tensorRT for python 3.8.12 on Jetson Xavier NX in virtual env.

I tried to follow the steps as mentioned [here] (https://docs.nvidia.com/deeplearning/tensorrt/install-guide/index.html#installing-pip):

  1. If I followed “Python Package Index Installation” using “python3 -m pip install --upgrade tensorrt” command getting error as
 note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for tensorrt
  Running setup.py clean for tensorrt
Failed to build tensorrt
ERROR: Could not build wheels for tensorrt, which is required to install pyproject.toml-based projects
  1. When I tried to download TensorRT, unable to locate the required package. My requirement is to install tensorrt 8.0.1 for ubuntu18.04 with aarch64 architecture with CUDA 10.2.


Required TensorRT Version: 8.0.1
CUDA Version: 10.2
CUDNN Version: 8.0.2
Operating System + Version: ubuntu 18.04, aarch64 architecture
Python Version: 3.8.12


We are moving this post to the Jetson Xavier NX forum to get better help.

Thank you.


We only provide Python 3.8 prebuilt in JetPack5.

If you prefer to use JetPack 4, please build the Python binding from the source.
Here is the tutorial for your reference:


@AastaLLL Thanks for the help, I am able to install it from the source.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.