Unable to run arduino ide on NVIDIA tx2 Developer Board

I am currently getting following error after trying to run arduino ide on tx2

nvidia@tegra-ubuntu:~/arduino-1.8.5$ ./arduino
Picked up JAVA_TOOL_OPTIONS: 
java.lang.UnsatisfiedLinkError: /home/nvidia/arduino-1.8.5/lib/liblistSerialsj.so: /home/nvidia/arduino-1.8.5/lib/liblistSerialsj.so: cannot open shared object file: No such file or directory (Possible cause: architecture word width mismatch)
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)
	at java.lang.Runtime.load0(Runtime.java:809)
	at java.lang.System.load(System.java:1086)
	at processing.app.Platform.loadLib(Platform.java:162)
	at processing.app.Platform.<clinit>(Platform.java:157)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:264)
	at processing.app.BaseNoGui.initPlatform(BaseNoGui.java:518)
	at processing.app.Base.<init>(Base.java:199)
	at processing.app.Base.main(Base.java:144)
/home/nvidia/arduino-1.8.5/lib/liblistSerialsj.so: /home/nvidia/arduino-1.8.5/lib/liblistSerialsj.so: cannot open shared object file: No such file or directory (Possible cause: architecture word width mismatch)
Cannot load native library /home/nvidia/arduino-1.8.5/lib/liblistSerialsj.so
The program has terminated!
nvidia@tegra-ubuntu:~/arduino-1.8.5$

I have added new JAVA excutable for arm64 as per this thread
https://devtalk.nvidia.com/default/topic/999109/jetson-and-newer-arduino-ide-help-/ but still no success

sds,
To run the package under Jetson TX2 Ubuntu image, you should have arm64 version of package. However, arduino site has linux 32, 64 and arm download and there is no arm64. So I tried arm version - assume 64 is x86 64. When running under command line, I got

nvidia@tegra-ubuntu:~/Downloads/arduino-1.8.1$./arduino
./arduino: line 35: /home/nvidia/Downloads/arduino-1.8.5/java/bin/java: No such file or directory

and I ran Arduino IDE icon after running install.sh, nothing comes up.
So,

  • is the package right aarch64 architecture build?
  • any other Java components required to run the IDE?

Might be helpful to check with Arduino and at the same time, let’s see any other developer had experience with the package in TX2 board.

Hai

I am using jetsontx2 for controlling servo using arduino nano via rosserial. But jetson is not able to find the arduino nano connected via usb port.as of my knowledge Arduino nano nuses ch341 driver to communicate with jetson. How can i resolve this issue sir