Unable to set nvidia kernel module parameters

I’m trying to follow this guide https://download.nvidia.com/XFree86/Linux-x86_64/450.66/README/powermanagement.html to enable saving the GPU video memory during suspend. It suggests to enable NVreg_PreserveVideoMemoryAllocations=1.
So, I have created /etc/modprobe.d/nvidia-power-management.conf with the following contents:

options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/mnt/vault/nvidia-tmp.

I have also added FILES=(/etc/modprobe.d/nvidia-power-management.conf) to mkinitcpio.conf, and have enabled all the modules for KMS: MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm) along with the proper kernel parameter.

However, when I check sudo systool -vm nvidia, I only see

Parameters:
nv_cap_enable_devfs = “1”

What can I do to make sure that these parameters are set properly? I have attached a nvidia-bug-report.sh output if it can be helpful. Thanks.

For the bug report I ran sudo systemctl suspend in a TTY, then resumed and switched back to X and ran the bug report. nvidia-bug-report.log.gz (505.4 KB)

Use

cat /proc/driver/nvidia/params

to see the current settings.
In general, you’ll also have to make the nvidia suspend/resume units work.