Unrecognised option '--gpu-metrics-device=0'

I am using Nsight System 2022.4.1.
After running nsys profile --stats=true --gpu-metrics-device=0 python3 multi_mem_test.py, it shows 【unrecognised option ‘–gpu-metrics-device=0’】.

Please help me solve the problem.
I wonder if this problem has any relation to “nsys version”. Because when i run nsys --version, the result is 2020.3.2.6-87e152c. But i am sure that NsightSystems-linux-public-2022.4.1.21-0db2c85.run is used to install Nsight System.

It seems that there might be multiple versions of Nsight Systems installed. Version 2020.3.2 will definatelly not support the gpu-metrics-device option.

When installing with the .run script, the default installation path will be /home/<user>/nsight-systems-2022.4.1, or one can provide a different path for installation. The executable for the installed version of Nsight Systems will be at <installation path>/bin.

1 Like

problem solved, thx very much

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.