USB Camera source not detected jetson nano

Hi,

I have a usb camera source device connected to jetson nano. The device is not detected on startup, but is detected after a reboot. What can be the issue for this?

Thanks in advanced

Hi,
It is very likely the signals(D+/D- pins) are not stable in the condition, so it fails in enumeration. A possible solution is to trigger enumeration after bootup. Please refer to this post:
Power down USB ports - #4 by vsaw

I tried the below commands

sudo uhubctl -l 1-2 -a off
sudo uhubctl -l 1-2 -a on

But after powering on I get the below message

Failed to open /dev/video0: Device or resource busy

Hi,
Do you use Jetson Nano developer kit? The command shall work on developer kit.

I tested these commands in the jetson nano developer kit. Power down command seems to work (the usb devices are turned off) but power on command is not working properly the video devices are not detected but the connected keyboard is detected

Hi @DaneLLL

The issue for not enumerating properly maybe due to the external USB hub connected to the jetson. But the below command solved the issue for me

sudo uhubctl -l 1-2 -a cycle -d 5 -R

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.