USB hard drive not recognized on USB 3.0 port

Hi there,

I’ve encountered some problem on TX1. I have some SSD hard drive like Samsung SSD T3, and it’s occasionally not recognized by TX1. It’s working 100% normally when successfully recognized, but when it’s not recognized, there’s even no output from command ‘dmesg’, not even an error, just like nothing has happened.

There’s some other information that I’ve collected:

  1. the power light on the hard drive is on when connected, even it’s not recognized yet.
  2. ‘dmeg’ has totally no output for the plug-in event
  3. sometimes other USB devices can still work normally, such as a small USB memory stick, USB mouse…
  4. sometimes any kind of USB devices is unrecognized.
  5. when the problem occurs, rebooting the machine sometimes can recover the function, and sometimes not.

Even there’s no output from ‘dmesg’ at the problem, but I still saw something when connecting other devices if it works at that time,

[ 1094.127515] platform d.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.127750] platform c9.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.127963] platform ca.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.128165] platform cb.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.128360] platform cc.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.128552] platform cd.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.128705] reg-fixed-sync-voltage ce.regulator: Consumer c0 does not have device name
[ 1094.128748] platform ce.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.128946] platform d1.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[ 1094.129139] platform d3.regulator: Driver reg-fixed-sync-voltage requests probe deferral

don’t know if it’s relative to this USB issue, and not sure if those message would come out when not in the problem.

You may disable usbcore autosuspend by adding


into /boot/extlinux/extlinux.conf.

If it is a power issue, using a powered USB hub would fix it.

+1 (it sounds very much like power delivery…especially if the drive is natively USB3 and placed on a USB2 bus or on a USB3 bus with other devices). Emphasize “powered” HUB.

forgot to mention that I’m using android system. is there some way else to reach that config in android?

No idea on android, it isn’t supported…you’d have to ask whoever did that release. Still sounds like a power issue though. Try the powered HUB.

I tried this, found on other forum, to disable ‘autosuspend’, but no luck

for line in $(find /sys-name control | grep usb)
echo on > $line

will try to power the hub next time it shows up.

You can try to disable usbcore autosuspend once after boot with

echo -1 > /sys/module/usbcore/parameters/autosuspend

if your version has this node available, but I’m not confident it will fix your problem.
The power issue looks the best candidate, so try a powered hub as soon as possible.

Thanks guys, but still no luck. I have tried this command too, and a powered hub, neither of these method work.

planning to check the hardware signal next…

It is unclear if you are facing problems only when the SSD is plugged in, but if yes and not yet done you may try another USB cable (recent, USB3, shortest as possible).

In most case it is occurring on the SSD only. I’m using the original cable provided by Samsung, and it never failed on my laptop so far.

But I will try another cable.

If it’s occurring without having plugged it, the cable is probably not the cause.
If you plug keyboard and mouse into a hub connected on micro-USB port and have just the SSD on USB3 port, does it still fail ?

I have removed all the other devices on this hub, it’s still the same.

Without any hub on USB3, just the SSD directly connected on Jetson USB3 ?

If it still fails without any error message, I cannot say much more.
There may be a HW problem.
My last guesses could be electrostatic (blow dust from jetson) or ground current with other powered devices (you may try to remove ethernet or HDMI cables if you have a serial console).

To clarify, did a HUB with external power (power drawn from a power adapter, not from USB itself) change anything? Having the system provide power versus external power source is a debug step…it isn’t about whether the USB bus is trying to provide power, it is about whether the bus is capable of providing enough power in a particular situation with specific hardware. USB power delivery is not always the most reliable power source.

No there’s a hub between the SSD and the Jetson USB3. So is it possible that the hub had rejected the SSD?

Yes I did try external power on an external hub, seems no changes.

In this case it may be of interest to see if anyone from NVIDIA has thoughts on this particular drive…make sure you post the exact specifications. The powered HUB would pretty much improve signals and power delivery, so the problem is likely something else.