USB powers, but that's the end of it...

Was working fine before, but now, all of a sudden, the port has stopped working. I can plug things into it, and they show a powered light on the device that is plugged in, but nothing can be done. When I type in a keyboard or move a mouse, nothing.

I see some mentions about USB woes, but no solutions that I could find or see from search.

Here’s lsusb output with a keyboard plugged in:
ubuntu@tegra-ubuntu:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any help for this?

I see only hubs internal to the jetson (I assume jetson) listed; no keyboard, mouse, etc. Power issues could cause devices plugged in to not show, or to work erratically.

I personally use a powered hub, one that is plugged into external power. People seldom realize how faulty the power requirements setup is on a lot of common motherboards…and jetson is a development kit, I doubt its ability to deliver power up to standards has been thoroughly tested (emphasis on “thoroughly”). A downstream port in theory should be able to deliver a tiny amount of power in standby, significantly more in power on, and even more if it is powered USB hub. Each downstream port power consumption adds up on a non-powered hub’s incoming upstream port requirements…if that in turn was a downstream port on another hub, it snowballs. I’ve found many flaky USB problems simply go away with a powered hub which consumes no power from the upstream. Unless your device being plugged in draws no power from the host, you really won’t know if there is a more significant failure. I use a couple of these for USB2, but any hub with a power adapter should work:

Does lsusb show any change if you plug and unplug each device one at a time?

Also, the kit comes with a micro-A/B port which can work as well (this is why there are 2 hubs internally I believe). The cable provided is a micro-B, so it can’t be used if the port is to act as a regular USB port (micro-B causes it to act as a device instead of a port)…you could get a micro-A cable/adapter and plug your device into that as a test from a separate internal hub.

Thanks for the suggestions! I actually was using a powered USB-hub originally, then I tried other devices just to see if it was the hub that was failing me.

I have used the hub and other devices successfully before, so I am puzzled why this is happening now. I tried several different outlets too thinking maybe it was a powering issue too, but to no avail.