USB ports doesn't work when specific device is connected

Hi, I have critical problem and i want any solution.

I’m using Jetson Tx2 and Intel Realsense SR300 device.
When i don’t connect SR300 to Tx2 USB ports doesn’t make problems and it works well. Keyboard and mouse are work well i mean.

But Once I connect SR300 USB ports looks doesn’t work. POWER button on Tx2 board works but all the USB devices stop working.
I wondered if SR300 has some problem, so i connected this device to my laptop and it works!

I tried both before connect AC power supply and after connect AC power supply to tx2 board. and It didn’t make sense on both side.
I want to know what can I do.

p.s. i tried both USB3.0 and USB2.0(micro USB) ports

Please check if below posts help your case:


I already installed pyrealsense library on TX2, you mean i should re-install realsense SDK or library. right?

we don’t have the device and may not be able to give further suggestion. Other users may share their experiences.

Thank you. I should wait someone who saves me

I saw a note that the Realsense SR300 is USB 3.1, but it didn’t say if USB3 was required. This is something which should be researched as a “high priority” for the question. Many higher speed cameras or devices do not work on USB 2. When such a device reverts to USB 2, then the device will cease to function. This may not be the case for you, but it mandatory to find out.

One thing you can do on a system where the device works (and I don’t mean only that the device doesn’t bring down the system…I mean where the device functions correctly) is to look at “lsusb -t”. This is a tree view. On the right side of each device listed there will be a speed noted. “480M” is 480Mb/s USB 2, and 5000M is 5000Mb/s USB 3.1 gen. 1. You’ll have to look carefully to narrow down which device the camera is, but find out if the camera functions under both a USB3 port and a USB2 port…if it fails under USB2, then you know this will never work.

In the case of USB 3 power requirements go up. To avoid any possibility that the device is simply drawing too much power you will need to plug the camera into a USB 3 powered HUB (a HUB with an external power supply does not draw power from the Jetson). If the Jetson still fails to boot, then you know it is not to due to power drain.

Make sure the Jetson port and any HUB used is USB 3. The micro-USB2 port is only capable of USB2, so this is ruled out.

Some further elaboration on USB2 versus USB3:

When a USB2 device is present there is certain information about the device or devices on the USB cable. In reality many USB devices are multiple devices on a single cable, e.g., a programmable mouse might show up as (1) a standard mouse, (2) a custom device which can be programmed, (3) a keyboard since a button might show up as a keyboard button, or even (4) a joystick if programming has that ability. Or a keyboard might show up as both a keyboard and mouse if it is either programmable or has a touch pad. If a USB3 device is backwards compatible with USB2, then each of those devices are basically duplicated in the identification sent to the host computer in both a USB3 and a USB2 section of the data. One section of data for USB3, and another section of data for USB2. If the device is not backwards compatible, then the USB2 section is basically left blank for one or more components of the device and there is no possibility that a driver might identify a device it can service since the device is essentially missing and never reported.