very low bandwidth bandwidth problem with Tesla C870

Hi!

I ran bandwidthTest with very low memcopy results:

Host to Device: 160MB/s
Device to Host: 200MB/s
Device to Device: 65GB/s (is ok)

The Tesla C870 Card is plugged in the pci express x16 slot in the mainboard ASUS P5B.

In another PCI slot a GeForce FX 5200 is installed. I hope thats not a problem…

Any ideas to solve this problem? Maybe any special Drivers/Settings in BIOS or WinXP necessary?

Can you advise some tools to check if the mainboard pci express bus works correctly?

EDIT: I’ve looked in the NVIDIA Control Panel -> Help -> System Info for Tesla C870. In Details of Tesla is Bus only set to PCI Express x1 instead of x16… I’ve checked the mainboards User Guide, google and so on… What is wrong???

Thanks for help!!!

tom

Thanks for your answer, but your formatting is a little bit unclear, maybe you can change that and not mixing up my question with your answer. Thanks!

I also used the --memory=pinned option, the results are nearly the same…

I think the real problem is the x1 link connection.

Try messing around in the BIOS. The slot speed is controlled in there.

Look for something along the lines of “Use PCI-Express slot for non-video devices” or somesuch.

Seemed I’ve solved the problem now…

After BIOS Update and installing newest Intel Chipset Drivers it works now with x16 Link…

So now I’ve uses the pinned memory option in bandwidthtest and get speeds of 2600MB/s for Host to Device and 1900MB/s for Device to Host, is this ok?

Thanks for your help!

Greetings, tom.

Not the best numbers, but in the right ballpark