Video4Linux Loopback Device on Linux4Tegera

I am interfacing Bumblebee2 camera with Nvidia Tegra TK1 board. I have installed firewire1394 driver along with coriander 2.0.2 to get the camera output and it is working fine. But I am not able to load the video for Linux module. I have installed the following two packages as well using synaptic.

v4l2loopback-utils
qv4l2

I have following version of Linux kernel on Nvida Tegra TK1 board.
uname -a

Linux tegra-ubuntu 3.10.40-grinch-21.3.4 #1 SMP PREEMPT Fri May 1 10:41:09 UTC 2015 armv7l armv7l armv7l GNU/Linux

I downloaded the stable version of Video4Linux Loopback Device from http://www.lavrsen.dk/foswiki/bin/view/Motion/VideoFourLinuxLoopbackDevice

I follow the steps mentioned in the readme file and when I tried to make it, I got the following errors.

make -C /lib/modules/3.10.40-grinch-21.3.4/build SUBDIRS=/home/ubuntu/vloopback modules
make: *** /lib/modules/3.10.40-grinch-21.3.4/build: No such file or directory.  Stop.
make: *** [all] Error 2

I would appreciate if someone can help me to install video for Linux loopback device.

Hi shahnawaz,

I follow this discussion https://bugs.launchpad.net/ubuntu/+source/vloopback/+bug/811349, and modify the Makefile can make this Video4Linux Loopback Device compilable on official R21.3 kernel:

Linux tegra-ubuntu 3.10.40-gc017b03 #1 SMP PREEMPT Mon Feb 2 17:50:48 PST 2015 armv7l armv7l armv7l GNU/Linux

It seems that your compiling procedure is stopped for the lack of this directory /lib/modules/3.10.40-grinch-21.3.4/build, please check if you install update the modules after installing The Grinch kernel https://devtalk.nvidia.com/default/topic/823132/embedded-systems/-customkernel-the-grinch-21-3-4-for-jetson-tk1-developed/:

sudo tar -C /lib/modules -vxjf jetson-tk1-grinch-21.3.4-modules.tar.bz2

Supposedly you could follow these steps to install Video4Linux Loopback Device on official R21.3 kernel:

  1. syc the project from svn repositary:
svn co http://www.lavrsen.dk/svn/vloopback/trunk/ vloopback
cd vloopback
  1. Build using v4l-utils headers:
sed -i 's/<linux\/\(videodev.h\)>/"libv4l1-"/' *.c example/*.c
  1. Recompile modules_prepare:
/usr/src/linux-headers-$(uname -r)
sudo make modules_prepare
  1. Delete the -Wall flag in example/Makefile:
CFLAGS=-g -Wall

To

CFLAGS=-g
  1. Now we can compile and install Video4Linux Loopback Device
make; make install

Thanks!

Yeah I am able to solve the problem, thank you