VNC viewer client for cloud connection on arm64

Hi there.
I’ve done quite a lot of attempts trying to install the VNC viewer from real VNC on my Jetson Nano B01.
I’ve tried to follow the procedure at: [RealVNC Server on UBUNTU 20.10 (ARM64) on Raspberry Pi 4 (8GB) - YouTube] - But I chose the viewer instead.
I got an installation error for missing libc6.

What I want to achieve is to use my Jetson Nano to connect to multiple “remote desktop” that are outside my LAN. real VNC offers a “cloud” connection option for this which I find convenient.

I’ve also tried to install teamviewer on the nano, but with the same problem. The nano is arm64, but it seems like the available software is for arm32/HF. I’ve also tried “NoMachine” which installs but does not seem to work either.

Have anyone found another software that works remote desktop connection (with viritual dekstop/graphic interface) that works for the Jetson Nano or do anyone know any suggestion for workoaround? Is what I am trying to do even possible, installing the “raspberry armHF” softwarevon a Jetson Nano?

Link to the .deb i tried to install:
Thank you for any suggestions/help.

I can’t answer this, but don’t use arm32/armhf. Stick to arm64/aarch64.

FYI, about the libc6, this is surprising. I see this on an R32.1 TX2:

# dpkg -l | egrep libc6
ii  libc6:arm64                                 2.27-3ubuntu1.2                            arm64        GNU C Library: Shared libraries
ii  libc6-dbg:arm64                             2.27-3ubuntu1.2                            arm64        GNU C Library: detached debugging symbols
ii  libc6-dev:arm64                             2.27-3ubuntu1.2                            arm64        GNU C Library: Development Libraries and Header Files

What do you see from “dpkg -l | grep libc6”? FYI, all those listed above are 64-bit. If you were using 32-bit software, then it would fail to find libc6 since it would want a 32-bit version.

Thank you. I get exactly the same lines , on my nano, as you from:

dpkg -l | egrep libc6

Yes, I suppose you are right but the arm64 does not seem to be available.

By default only arm64 is available on a 64-bit Jetson. For anything else 32-bit this would have required manually adding in 32-bit as a foreign architecture (which could greatly mess things up). Does your Jetson not show arm64 for libc6?