Which docker version is available for running aneurysm.py in modulus-sym v1.0.0

I want to run the code of aneurysm.py in the modulus-sym v1.0.0. I’m running Docker image v23.05, and I confirmed helmholtz.py works well. However, when I run aneurysm.py, I get the following error. If you know the suitable Docker version for running aneurysm.py, please let me know. Thank you for your cooperation.


Error executing job with overrides:
Traceback (most recent call last):
File “aneurysm.py”, line 44, in run
inlet_mesh = Tessellation.from_stl(
File “/usr/local/lib/python3.8/dist-packages/modulus/sym/geometry/tessellation.py”, line 219, in from_stl
mesh = np_mesh.Mesh.from_file(filename)
File “/usr/local/lib/python3.8/dist-packages/stl/stl.py”, line 377, in from_file
name, data = cls.load(
File “/usr/local/lib/python3.8/dist-packages/stl/stl.py”, line 94, in load
name, data = cls._load_binary(fh, header)
File “/usr/local/lib/python3.8/dist-packages/stl/stl.py”, line 111, in _load_binary
assert count < MAX_COUNT, ('File too large, got %d triangles which ’
AssertionError: File too large, got 1630942564 triangles which exceeds the maximum of 100000000

Set the environment variable HYDRA_FULL_ERROR=1 for a complete stack trace.

I am also getting the same error.
Modulus support team’s guidance would be highly appreciated.

I got the same error on Docker image v24.04.
A workaround is to change the value of MAX_COUNT from 1e8 to 1e10 in the stl.py file.
However, I would like to know if there is a reason for that 1e8 limit.