Why TitanBlack's Graphic Memory Clock is only 6000MHz when I run my CUDA program?

I have a TitanBlack card,recently I found the card’s real Graphic Memory Clock is only 6000MHz,not the 7000MHz by default when I run any CUDA program.I had changed many drivers,but them not effect the Memory Clock. Someone can tell me how to achieve the 7000MHz when I use the card under CUDA enviroment? My develop enviroment is: Windows 7 64bit,Cuda SDK 6.5.Driver is the latest Version 340.72.Thank you!

How are you determining the memory clock?

What does the driver control panel “system information” report for memory clock?

I use Gpu-Z tool to monitor the Gpu memory clock.When I run cuda program, the clock is 1499MHz, when I run 3DMark2011,the clock is 1749MHz.

Do you have the full-speed double precision mode enabled? (open the NVIDIA Control Panel, navigate to “Manage 3D Settings” and under the Global Settings tab find the option titled “CUDA – Double Precision”) If so, what results do you get when you disable it (and run a CUDA program)?

I used single float only. I will try double mode.thx