Unable to change GPU memory Clock Quadro P2000

Hello All,

I have problems setting memory clock.

When i try to change MEM Clock to 810 Mhz and SM Clock to 506, SM clock settting succesfull, but nothing changes on Memory Clock.

nvidia-smi -pm 1
nvidia-smi -ac 810,506 -i 0
nvidia-smi -q -d CLOCK

==============NVSMI LOG==============

Timestamp                           : Thu Dec 13 06:13:05 2018
Driver Version                      : 410.72
CUDA Version                        : 10.0

Attached GPUs                       : 1
GPU 00000000:83:00.0
    Clocks
        Graphics                    : 506 MHz
        SM                          : 506 MHz
        Memory                      : 3499 MHz

        Video                       : 658 MHz
    Applications Clocks
        Graphics                    : 506 MHz
        Memory                      : 810 MHz
    Default Applications Clocks
        Graphics                    : 1075 MHz
        Memory                      : 3504 MHz
    Max Clocks
        Graphics                    : 1721 MHz
        SM                          : 1721 MHz
        Memory                      : 3504 MHz

        Video                       : 1556 MHz
    Max Customer Boost Clocks
        Graphics                    : 1721 MHz
    SM Clock Samples
        Duration                    : 52136.54 sec
        Number of Samples           : 76
        Max                         : 1721 MHz
        Min                         : 139 MHz
        Avg                         : 1075 MHz
    Memory Clock Samples
        Duration                    : 52133.32 sec
        Number of Samples           : 76
        Max                         : 3504 MHz
        Min                         : 405 MHz
        Avg                         : 408 MHz
    Clock Policy
        Auto Boost                  : N/A
        Auto Boost Default          : N/A

As you see below mclk is still 3499 but i set it to 810.

# gpu   pwr gtemp mtemp    sm   mem   enc   dec  mclk  pclk
# Idx     W     C     C     %     %     %     %   MHz   MHz
    0    17    44     -     0     0     0     0  3499   506
    0    21    44     -    36     6    50    28  3499   506
    0    22    44     -    98    14   100    48  3499   506

When i check GPUPerfModes, it says “editable=0”

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -q '[gpu:0]/GPUPerfModes'

  Attribute 'GPUPerfModes' (ffmpeg-4:0[gpu:0]): 

perf=0, nvclock=139, nvclockmin=139, nvclockmax=607, nvclockeditable=0, memclock=405, memclockmin=405, memclockmax=405,
  memclockeditable=0, memTransferRate=810, memTransferRatemin=810, memTransferRatemax=810, memTransferRateeditable=0 ; 

perf=1, nvclock=139, nvclockmin=139, nvclockmax=1721,
  nvclockeditable=0, memclock=810, memclockmin=810, memclockmax=810, memclockeditable=0, memTransferRate=1620, memTransferRatemin=1620, memTransferRatemax=1620,
  memTransferRateeditable=0 ; 

perf=2, nvclock=139, nvclockmin=139, nvclockmax=1721, nvclockeditable=0, memclock=3504, memclockmin=3504, memclockmax=3504, memclockeditable=0,
  memTransferRate=7008, memTransferRatemin=7008, memTransferRatemax=7008, memTransferRateeditable=0

I tried to set rateofset, it returns “it is a read-only attribute”.

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a '[gpu:0]/GPUMemoryTransferRateOffset[0]=1000'

ERROR: The attribute 'GPUMemoryTransferRateOffset' specified in assignment '[gpu:0]/GPUMemoryTransferRateOffset[0]=1000' cannot be assigned (it is a read-only attribute).

Also locked gpu clocks is not supported.

nvidia-smi -lgc 810,506
Setting locked Gpu clocks is not supported for GPU 00000000:83:00.0.
Treating as warning and moving on.

Is there any other way to change memory clock permanently?

nvidia-bug-report.log.gz (836 KB)

is there anyone with experience about this problem?

The gpu clock setting requires a specific matching memory clock, so you can’t set them independently to any desired value.
https://devblogs.nvidia.com/increase-performance-gpu-boost-k80-autoboost/