BUG 378/381: nvml/nvidia-smi core clock is wrong on pascal devices

Core/SM/Video Pascal Clocks are wrong, they show 137 MHz while working… (P2)

Same thing is happening in the windows 378 via nvidia-smi and nvml api. NVAPI is ok.

try “nvidia-smi -q”

All is ok if i return on the previous ones 375.26 on linux or 376 on win

tested on the 1080, 1070 and 1060 (and different OS)

378.13 fail

Clocks
         Graphics                    : 30 MHz
         SM                          : 30 MHz

375.39 ok

Clocks
         Graphics                    : 1708 MHz
         SM                          : 1708 MHz

Can confirm on a 1070 in Arch Linux

Clocks
        Graphics                    : 62 MHz
        SM                          : 62 MHz

nvidia-settings returns the correct clock speed

Graphics Clock: 2060 Mhz

Bump, same in 381.09

sometimes i feel i write in white on a white background

We are tracking this issue under bug 1910463

Could you please help to get clock output with both nvidia-settings and nvidia-smi for 381.09, 378.13, 375.39 and 375.26 drivers? In comment #2 you said issue reproduced on 378.13 and not reproduced on 375.39 , please confirm? Is it for both nvidia-settings and nvidia-smi tools?

I confirm, and this problem affects nvidia-smi and nvml api (only) on both platforms since the 378

375.26

Clocks
        Graphics                    : 1835 MHz
        SM                          : 1835 MHz
        Memory                      : 3802 MHz
        Video                       : 1645 MHz

367.57

Clocks
        Graphics                    : 1708 MHz
        SM                          : 1708 MHz
        Memory                      : 3802 MHz
        Video                       : 1544 MHz

Wow, you finally noticed a 5 months old bug: https://devtalk.nvidia.com/default/topic/977051/-381-xx-bug-nvidia-settings-and-nvidia-smi-incorrectly-report-gpu-clock-speed/

Heh, I noticed this as well around the same time with a Pascal-based Quadro and GTX card as well. The wrong clock speeds also appear on the nvidia-settings GUI on Linux.

Not fixed in 381.89 (windows nvml/nvidia-smi)

This issue is still under investigation and not yet fixed.

It affects Windows as well? Oh, wow ;-)

was fixed on windows 382.x, there is some hope :) thanks

Looks like this has been fixed with the latest driver.

OS: Arch Linux
Kernel: 4.10.13
Driver: 381.22
GPU: GTX 1070

Clocks
        Graphics                    : 2075 MHz
        SM                          : 2075 MHz
        Memory                      : 3898 MHz
        Video                       : 1797 MHz

indeed, looks good… btw look like the --update feature (of the 375.66) is no more working, i guess it was using the ftp…

I am also 381.22 with Lubuntu.
Card: GTX 1060

Still have this bug

We have fixed this issue. Fix will be available in next driver release.

No - you haven’t.

NVIDIA-SMI 384.90 Driver Version: 384.90

root@intel:~/directory# nvidia-smi -rac
Setting applications clocks is not supported for GPU 00000000:17:00.0.
Treating as warning and moving on.
Setting applications clocks is not supported for GPU 00000000:65:00.0.
Treating as warning and moving on.
All done.

(GPUs: GeForce 1080Ti)


NVIDIA-SMI 387.22 Driver Version: 387.22

nvidia-smi -ac 2505,1137

Setting applications clocks is not supported for GPU 00000000:01:00.0.
Treating as warning and moving on.
All done.

(GPU: Quadro M2000M)

Nothing works, 1080Ti performance bad as sh*t.


In comparison to 1050Ti OC

NVIDIA-SMI 387.12 Driver Version: 387.12

Clocks
Graphics : 1303 MHz
SM : 1303 MHz
Memory : 3504 MHz
Video : 1177 MHz
Applications Clocks
Graphics : N/A
Memory : N/A
Default Applications Clocks
Graphics : N/A
Memory : N/A
Max Clocks
Graphics : 1923 MHz
SM : 1923 MHz
Memory : 3504 MHz
Video : 1708 MHz

nvidia-smi -ac 3504,1923

Setting applications clocks is not supported for GPU 00000000:07:00.0.
Treating as warning and moving on.
All done.

Why do I even bother?

To the nvidia team, is there any plan / roadmap on putting back NVML at par with nvidia-settings in terms of powermizer mode / auto-boost / etc … ?

Pascal devices are basically considered as unsupported

Regarding clocks, I understand that it needs a modification of the NVML API to switch from discrete clock numbers, to offsets for instance

Pascal architecture has been there for quite some time now and we are in the dark regarding ad-hoc support.
Any information would be greatly appreciated.

Same as above for GTX 1060:

[Commands run while running ccminer on the box (note P2 downgrade from P0 pre-application start)]

root@SlackMiner:~/bin# nvidia-smi -q -i 1 -d PERFORMANCE

==============NVSMI LOG==============

Timestamp : Mon Jan 1 17:53:06 2018
Driver Version : 384.98

Attached GPUs : 2
GPU 00000000:06:00.0
Performance State : P2
Clocks Throttle Reasons
Idle : Not Active
Applications Clocks Setting : Not Active
SW Power Cap : Not Active
HW Slowdown : Not Active
Sync Boost : Not Active
SW Thermal Slowdown : Not Active


root@SlackMiner:~/bin# nvidia-smi -q -i 1 -d SUPPORTED_CLOCKS

==============NVSMI LOG==============

Timestamp : Mon Jan 1 17:53:35 2018
Driver Version : 384.98

Attached GPUs : 2
GPU 00000000:06:00.0
Supported Clocks : N/A


root@SlackMiner:~/bin# nvidia-smi --auto-boost-default=ENABLED -i 1
Enabling/disabling default auto boosted clocks is not supported for GPU: 00000000:06:00.0.
Treating as warning and moving on.
All done.


root@SlackMiner:~/bin# nvidia-smi -ac 9900,9604 -i 1
Setting applications clocks is not supported for GPU 00000000:06:00.0.
Treating as warning and moving on.
All done.


root@SlackMiner:~/bin# nvidia-smi -q -i 1 -d CLOCK

==============NVSMI LOG==============

Timestamp : Mon Jan 1 17:57:34 2018
Driver Version : 384.98

Attached GPUs : 2
GPU 00000000:06:00.0
Clocks
Graphics : 2062 MHz
SM : 2062 MHz
Memory : 4799 MHz
Video : 1847 MHz
Applications Clocks
Graphics : N/A
Memory : N/A
Default Applications Clocks
Graphics : N/A
Memory : N/A
Max Clocks
Graphics : 1961 MHz
SM : 1961 MHz
Memory : 4004 MHz
Video : 1708 MHz
Max Customer Boost Clocks
Graphics : N/A
SM Clock Samples
Duration : 151.43 sec
Number of Samples : 70
Max : 2100 MHz
Min : 139 MHz
Avg : 1573 MHz
Memory Clock Samples
Duration : 151.58 sec
Number of Samples : 70
Max : 5004 MHz
Min : 405 MHz
Avg : 3666 MHz
Clock Policy
Auto Boost : N/A
Auto Boost Default : N/A


Like alexandrejabuisine and gpuxplorer said before; What is the ETA for a fix of this issue?

Issue still present using driver package 384.111

root@SlackMiner:/usr/local# nvidia-smi -q -i 1 -d PERFORMANCE

==============NVSMI LOG==============

Timestamp : Mon Jan 8 20:26:26 2018
Driver Version : 384.111

Attached GPUs : 2
GPU 00000000:06:00.0
Performance State : P2
Clocks Throttle Reasons
Idle : Not Active
Applications Clocks Setting : Not Active
SW Power Cap : Not Active
HW Slowdown : Not Active
Sync Boost : Not Active
SW Thermal Slowdown : Not Active