No supported clocks

I can’t get/set clocks for Asus GTX 1080 card.
Ubuntu 16.04, driver 381.22 from ppa:graphics-drivers/ppa.

$ nvidia-smi -i 0
Thu Jun 29 18:23:35 2017
±----------------------------------------------------------------------------+
| NVIDIA-SMI 381.22 Driver Version: 381.22 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 1080 Off | 0000:01:00.0 Off | N/A |
| 50% 64C P2 197W / 198W | 630MiB / 8112MiB | 100% Default |
±------------------------------±---------------------±---------------------+

$ nvidia-smi -i 0 -q -d SUPPORTED_CLOCKS

==============NVSMI LOG==============

Timestamp : Thu Jun 29 18:24:09 2017
Driver Version : 381.22

Attached GPUs : 1
GPU 0000:01:00.0
Supported Clocks : N/A

How to fix the perfomance state? I have ROG-STRIX-GTX1080-O8G-11GBPS card with 11GHz memory clock, but every time I start any app card enters P2 state and memory clock falls to 9GHz. The only way to put it back to 11GHz is to set an offset, but it applies to all perfomance states and closing the app switches card to P3 state with 13GHz memory clock which hangs the entire system.

Guys, this is not an overclocking, I just want to achieve factory clocks I paid for. What’s the problem?

https://pixz.ru/ZxKgGZBqajUn9BK2/f.png
https://pixz.ru/ZxKgGZBqahIXgkLl/f.png

Love you NVIDIA! (what Linus Torvalds never said).

Hi Lisio, Thanks for reporting this issue. Can I get nvidia bug report and detail reproduction steps for this issue?

I can’t download : https://pixz.ru/ZxKgGZBqajUn9BK2/f.png
https://pixz.ru/ZxKgGZBqahIXgkLl/f.png

https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

Hi, I fixed the links.

I have 2 cards (ASUS ROG-STRIX-GTX1080-O8G-11GBPS and ASUS ROG-STRIX-GTX1080TI-O11G-GAMING). As soon as I start any CUDA app and card enters compute mode it lowers memory clocks from 11GHz to 9GHz for 1080 and from 11GHz to 10GHz for 1080Ti.

It can be easily reproduced by starting any CUDA app, for example this one - http://wili.cc/blog/gpu-burn.html

Can you also test with 384.47 (beta) driver https://devtalk.nvidia.com/default/topic/1016125 ? Any earlier driver were you have not seen this issue?

I’ve tried recently released 384.47 drivers and didn’t notice any changes:
https://pixz.ru/ZyrRMiDYBMZhjbg4
https://pixz.ru/ZyrRMiDYBRQX8IUz
https://pixz.ru/ZyrRMiDYBMn97tYR

Can I get nvidia bug report log file as soon as issue issue hit?
>>The only way to put it back to 11GHz is to set an offset
What offset values you are setting for for graphics and memory when issue hit?
>>closing the app switches card to P3 state with 13GHz memory clock which hangs the entire system.
Did you see any error when hang entire system?

Can I get nvidia bug report log file as soon as issue issue hit?
Where can I get it?

What offset values you are setting for for graphics and memory when issue hit?
For 1080: +2000 MHz for memory, GPU clocks left untouched
For 1080Ti: +1000MHz for memory, GPU clocks left untouched

Did you see any error when hang entire system?
No, system hangs without any errors and log messages. Under Windows I can see only visual artefacts when it hangs if card was connected to monitor.

I think you have not gone through https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

Please always include a copy of an nvidia-bug-report.log.gz file, which can be generated with the nvidia-bug-report.sh script shipped with the NVIDIA Linux/FreeBSD graphics drivers and installed in your PATH; the log file will be placed in the current working directory.

Attaching 2 reports:
cuda.log.gz was made when both cards were in compute mode
idle.log.gz was made when both cards were in idle state
cuda.log.gz (260 KB)
idle.log.gz (260 KB)