Setting applications clocks is not supported

Hi everybody,

I just got 2 EVGA GTX 1070 FTW cards. Everything works fine except that I am not able to overclock the cards. When I try to use the ‘‘nvidia-smi ac’’ I get the following message:

‘Setting applications clocks is not supported for GPU 0000:01:00.0.’

I have driver version 375.66 installed as well as CUDA 8.0. I have Ubuntu 16.04.

Anyone has any ideas? I have searched for many days to find a solution but coudn’t find something that works for me.

Thanks a lot in advance.

Are u using ssh or direct access? (must use 2nd)

You can not overclock without powermizer in xorg. You need to use coolbits.


was ment to use lower clocks that stock but you can query for supported clocks:

nvidia-smi -q

if u want to overclock you need to use presistent mode (demon) coolbits and nvidia-xconfig

nvidia-persistenced --persistence-mode  #first run deamon
nvidia-smi -pm ENABLED  #2nd enable persistenced mode
nvidia-smi -pl 130  #limit TDP if u want

to run coolbits all GPU must be seen in nvidia-setting by xorg, if not :

nvidia-xconfig -a, --enable-all-gpus  #this add every screen for every gpu to xconfig.conf

now we can run collbits

nvidia-xconfig -cool-bits=28 #now u can control core & mem clocks and termal setting in xorg.

use this from console or make script if u want to auto overclock (can use crontab):

nvidia-settings -a "GPUMemoryTransferRateOffset[3]=value"
nvidia-settings -a "GPUGraphicsClockOffset[3]=value"