Problem with overclocking 1060 on ubuntu 16.04 and 17.10

Hello,

first of all I will list my setup here. Already took few weeks of my life and it still doesnt work.

H110 Pro BTC+ (already used second MB)
8x MSI GeForce GTX 1060 AERO ITX 3G OC (connected with risers)
Ubuntu 16.04 and 17.10
monitor attached to MB no attached monitors or plugs to GPUs

nvidia-smi - 384.90
nvidia-settings -v - 361.42
xorg file before (https://pastebin.com/a4DdnSGN)
xorg file after (https://pastebin.com/xTR9Q2jX)

So what I am trying to achive is to overclock all these cards for maxmimum performance. I have already managed to power limit them succesfully with

sudo nvidia-smi -pl 60

.

The problem is when I try to overclock the cards with these commands it gives me error line.

The command lines:

nvidia-settings -a '[gpu:0]/GPUGraphicsMemoryOffset[3]=25'

nvidia-settings -a '[gpu:0]/GPUGraphicsMemoryOffset[3]=25' (Unrecognized
   attribute name).

nvidia-settings -a GPUGraphicsClockOffsetAllPerformanceLevels=50

nvidia-settings -a 'GPUGraphicsClockOffsetAllPerformanceLevels=50' (Unrecognized
   attribute name).

Any of these doesnt work.

What have I tried:

Different systems (16.04, 17.10, 17.10 server)
Changed MB.
Tried with one GPU or all 8 gpus.

Problem n1:
I have tried to update nvidia drivers with the ones on nvidia website .run. But I couldnt managed to install them because I havent managed to disable nouveau and properly to install them (even when I blacklisted nouveau in configs). So I am using drivers from software update in linux.

Problem n2:
While I edit xorg.conf and add coolbits to it. Reboot system then it has problems with login (even when login screen is disabled) after a minute in stuck freezed login, its unfeezed and I managed to log in. But coolbits arent in xorg config (it is automaticly changed to default?).

What can I do? Is there any hope?

Thanks for the answers.