[SOLVED] Overclocking Issue on ubuntu 16.04, RTX 3080, driver 455.23.05

Sorry if this questions sound a little dumb, but has anyone faced this issues?

I am using:

  • Ubuntu 16.04
  • 2 GPUs RTX 3080 (EVGA RTX 3080 XC3 Ultra, MSI RTX 3080 Ventus 3X)
  • Asus B250 Mining Expert
  • Nvidia Driver 455.23.05, CUDA 11.1

What I am trying to achieve:

  • I wanted to set the application, memory clock, and fan speed

What I have been doing so far that is successful:

  • I have been able to trigger persistence mode in nvidia-smi
  • Set the power limit with nvidia-smi

What I have been doing that failed:

  • I am not able to trigger coolbits via CLI or even edit it onto the xorg.conf. (I have added Option "Coolbits" "28" inside the xorg.conf)
  • I created a new folder in /etc/X11/xorg.conf.d and make a file nvidia.conf with the property like such
#StartLine
Section "Device"
     Identifier "Device0"
     Driver "nvidia"
     VendorName "NVIDIA Corporation"
     BoardName "Geforce RTX 3080"
     BusID "PCI:11:0:0"
     Option "Coolbits" "28"
EndSection

Section "Device"
     Identifier "Device1"
     Driver "nvidia"
     VendorName "NVIDIA Corporation"
     BoardName "Geforce RTX 3080"
     BusID "PCI:13:0:0"
     Option "Coolbits" "28"
EndSection
#EndLine
  • Everytime I reboot the system, all the config does not persist and has been overriden, gist.github.com
  • I tried to trigger the nvidia-smi -q -d SUPPORTED_CLOCKS, i have enabled -pm 1 on both GPU, but the result showing N/A, microway.com

==============NVSMI LOG==============

Timestamp                                 : Sat Jan  9 16:29:36 2021
Driver Version                            : 455.23.05
CUDA Version                              : 11.1

Attached GPUs                             : 2
GPU 00000000:0B:00.0
    Supported Clocks                      : N/A

GPU 00000000:0D:00.0
    Supported Clocks                      : N/A
  • I also tried using the ppa repository, but the outcome is mismatch version, the one from NVIDIA Cuda 11.1 is the working installation for me
    ps: sorry i need to remove the link, new user cannot add more than 3 links https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them

All the helps is much appreciated.
Thank you in advanced!

nvidia-bug-report.log.gz (1.4 MB)

The gpu-manager in Ubuntu 16.04 overwrites the xorg.conf on boot. To disable this behaviour, please add the kernel parameter
nogpumanager
Then your own xorg.conf should stick.

Thankyou for the reply!

I have edited the file on etc/default/grub and added the nogpumanager but unfortunately the problem still persists. I am still not able to overclock it somehow.

I have just tried to use sudo chattr +i /etc/X11/xorg.conf with the value inside the file is being generated by sudo nvidia-xconfig -a and I added Option "Coolbits" "24". It does able to prevent modification, but I always stuck on login loop.

Tried this reference askubuntu but also no go.

I try to reinstall the OS, and just go with installing driver and sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration and after I reboot, it stuck as such

Any other advice that you aware of?
Thankyou in advanced!

Your monitor is connected to the onboard intel gpu so you need a prime setup. Just take the xorg.conf that gpu manager created and modify that. You can find it in the nvidia-bug-report.log
Or just add the igpu to your xorg.conf as first device.

I finally able to set the things correctly just like you said, thank you, all the best mate!