xorg.conf Ubunutu 16.04 LTS GTX 1070 Enabling Coolbits

Computer Type: Custom build
GPU: Gigabyte GTX 1070 OC Windforce, 8GB of VRAM x3
CPU: Intel Core i5 6600k, no overclock
Motherboard: MSI Z170A GAMING M5 Click Bios 5
RAM: Ballistix 8GB (2x4GB) DDR4 2400MHz, no overclock
PSU: FSP Aurum PT Series, PT-1200FM, 1200 watt, 12volt
Operating System & Version: Ubuntu 16.04 LTS
GPU Drivers: 381.22 drivers, clean install / CUDA 8.0

Description of Problem:

I was wondering how to enable coolbits on my mining rig?

Basically, the problem I’m having is that every time I add Option “Coolbits” “28” under the device settings on the xorg.conf file it doesn’t save it after rebooting. It resets to the original file settings.

Steps I’ve tried:

  1. changing ownership from root to myself + read/write settings.
  2. Tried editing with gksudo + gedit
  3. Tried editing with nano

I’ve done everything from change ownership / write settings where I can edit the file and save it. Except, when it saves it actually saves a dated version of it. EX: xorg.conf.0618207

Here’s an example of one of the device settings in the config file:

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:3@0:0:0”
Option “ConstrainCursor” “off”
EndSection

What I’m attempting to do is add Option “Coolbits” “28” underneath Option “ConstrainCursor” “off”. It will save but when I restart xorg.conf will revert back to the default file. After multiple times I’m not sure why it will save on the computer (both in the original and in the generated save file) and then when it boots it reverts back to the original xorg.conf settings.

Thanks in advance!

Rig Settings
±----------------------------------------------------------------------------+
| NVIDIA-SMI 381.22 Driver Version: 381.22 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 1070 Off | 0000:03:00.0 Off | N/A |
| 47% 62C P2 129W / 180W | 2426MiB / 8114MiB | 100% Default |
±------------------------------±---------------------±---------------------+
| 1 GeForce GTX 1070 Off | 0000:04:00.0 Off | N/A |
| 51% 65C P2 135W / 180W | 2186MiB / 8114MiB | 100% Default |
±------------------------------±---------------------±---------------------+
| 2 GeForce GTX 1070 Off | 0000:05:00.0 Off | N/A |
| 34% 56C P2 123W / 180W | 2186MiB / 8114MiB | 100% Default |
±------------------------------±---------------------±---------------------+

I recreate my xorg.conf file using the following command…

sudo nvidia-xconfig -a --cool-bits=28

This adds both my 970 and 1070. My only problem is I can overclock the 970 but not the 1070 as it errors with an unsupported msg (nvidia-smi -i 0 -ac 4004,1911), used the standard nvidia-375 drivers as well as the latest nvidia-381. Have you managed to get this working?