(Solved) coolbits without xorg.conf?

hi all and nv devs,
i’m on kubuntu 14.10 64b with 346.47 drivers, and i’ve noticed that there’s no xorg.conf any more (at least, it isn’t created by default, and there’s an nvidia-persistenced service going on in the background). i wanted to enable the coolbits options as always, but is there a way to do it outside of the option in xorg.conf?

Check folder /etc/X11/xorg.conf.d/, there should be xorg config files.

i have no /etc/X11/xorg.conf.d… but i found it under /usr/share/X11/xorg.conf.d, thou there is no xorg.conf inside. just a bunch of different .confs for various hardware. no nvidia or graphics anywhere…

So what if there’s no xorg.conf. Create it. All you need is a Device section.

cat /etc/X11/xorg.conf.d/nvidia.conf
Section "Device"
        Identifier      "Videocard0"
        BusID           "PCI:1:0:0"
        Driver          "nvidia"
        VendorName      "NVIDIA"
        BoardName       "NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)"
        Option          "Coolbits" "12"
        Option          "RegistryDwords" "RMUseSwI2c=0x01; RMI2cSpeed=100"

# This is a trailing line, it is needed so that End Section is not the last line

You may want to remove/change BusID. You’ll definitely won’t need RegistryDwords (it’s a hack for a bug regarding I2C).

guess what, i already tried it. every xorg.conf i put into just crashes x at startup. i tried different versions made both from scratch and from nvidia-settings. minimalistic (only the device section) and full fledged. as a longtime linux user i’ve being dealing with xorg.conf since when you had to manually input modelines and stuff.

at birdie: thanx a lot i’ll use it as a template. one question though, does X11 just parse the whole xorg.conf.d automatically for .confs or do i have to make it load each conf from some script?

It reads xorg.conf plus everything in xorg.conf.d automatically. If you’re having trouble getting the X server to start, please generate an nvidia-bug-report.log.gz immediately after a failed attempt and post it here.

ok, i just created a 52-nvidia.conf in /usr/share/X11/xorg.conf.d/ with this content:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 660 Ti”
Option “Coolbits” “28”
Option “TripleBuffer” “True”

using the nvidia-settings created conf for the device info and adding the options.

it works perfectly fine. thnx Mr plattner and everybody.

btw. any other options besides triple buffering can be useful?

Good that you got it working. But for the record, in order to be able to get help, it isn’t enough to just say “I tried several configs and it crashed”, it’s to show us the configs you tried and the errors that resulted from it. We didn’t even know you tried any configs from what little info you posted.

look. i really understand this, but keep in mind that my question was about NOT using xorg.conf. i like the idea of the nvidia service handling the video configuration, and even the smaller confs in xorg.conf.d are easier to deal with for me.
my question was: “how can i set the nvidia options without using xorg.conf?” and the answer came just a couple of brief posts later: “just put a “device”.conf in xorg.conf.d”.
then again, i really had every xorg.conf crashing at x startup as described. put for me it’s not an issue any more. so, if the devs need some info on that, i can get back to creating xorg.confs and tracing crashes. but this is just if they really need them. it’s a boring process :)

Option "Coolbits" "28"

But why? Where from did you take this number?

I guess it’s
4(thermal monitor page will allow configuration of GPU fan speed)
8(allows setting per-clock domain and per-performance level offsets to apply to clock values)
16(the nvidia-settings command line interface allows setting GPU overvoltage)

28(potentially fried gpu)…

lol exactly

I am not sure if I should reply to this thread as it is marked as solved, but I’ve got the exactly same problem. After generating Xorg.conf with nvidia tool I am not able to load gdm/gnome due to the black screen and non-blinking cursor in the upper left part. I am using Fedora 30.
I’ve noticed that problem is caused by

Driver "nvidia"

section, not sure though what is missing.

The following config works:

Section "Module"
    Load "modesetting"

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "AllowEmptyInitialConfiguration"
    Option         "Coolbits" "28"

Same here using Pop!_OS.